Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

lostregr123

macrumors newbie
Original poster
Nov 1, 2019
24
0
Macbook Pro 15

one of the 4 USB C's has gone off . i did an update in catalina but it was not fixed.


I have tried i believe correctly NVRAM / SMC resets but no success ...
I have passed a diagnostic test.
I have tried safe boot again nothing.



When i try to plug in something it pops this message (In mojave I have never received a pop like this)


Screenshot-2020-03-18-at-2-20-36-PM.jpg



Somehow I believe that something with electric circquits, electricity from my Displays USB C charge has been evolved in this case.
My display is a Dell 3219Q USB C.

Any ideas what to try?
 

Fishrrman

macrumors Penryn
Feb 20, 2009
24,672
9,912
My suggestion (no promises, you may have already done this):
1. Power off MacBook
2. DISCONNECT anything and everything attached to the other USB ports
3. NOW do an SMC reset
4. Reboot and get to the finder
5. NOW try connecting something to the "problem port" BEFORE you attach anything else.
Any difference...?
 

lostregr123

macrumors newbie
Original poster
Nov 1, 2019
24
0
My suggestion (no promises, you may have already done this):
1. Power off MacBook
2. DISCONNECT anything and everything attached to the other USB ports
3. NOW do an SMC reset
4. Reboot and get to the finder
5. NOW try connecting something to the "problem port" BEFORE you attach anything else.
Any difference...?

tried, nothing.

tried both SMC reset methods, nothing.

tried even SMC + New User nothing.
 

Fishrrman

macrumors Penryn
Feb 20, 2009
24,672
9,912
I'd say your next step ought to be to take it to a brick-n-mortar Apple Store genius bar and let them have a look at it...
 

lostregr123

macrumors newbie
Original poster
Nov 1, 2019
24
0
after some experimentation.

Connect first to the Dell monitor, cable -> charges.
then I connect also the Apple charger to the problematic USB C port it charges.
I unplug the dell cable, then it charges from the problematic USB C port.



I tried while plugged in and powered the hunt to SMC reset but I failed.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.