USB Cable not working on Mac

Discussion in 'MacBook Pro' started by Filipgurcinovsk, Oct 9, 2014.

  1. Filipgurcinovsk macrumors newbie

    Joined:
    Oct 9, 2014
    #1
    Hello, I am new to the forums, but an experienced Mac user. I recently got a Canon Eos50D DSLR and wanted to import images onto my mid 2012 macbook pro running the latest version (10.9.5)

    When i plug in the camera using 4 different usb cables, non of them work, not even in the slightest, camera doesn't show up in finder, desktop, iPhoto doesn't launch, doesn't show up in disk utility. Its like there's nothing in the USB Port. The USB Port works fine, works with any USB I tried. I then tried to connect a video camcorder, using once again, 4 different cables, and still 0 response. I have tried on another very similar macbook pro and a iMac 27 Inch; Same thing. I have come to the conclusion that either all 4 USB cables are broken (Highly, Highly unlikely) or the usb ports on the camcorder, the Canon and i also tried a external hardrive which also would not show up, do not work (Also, highly unlikely)

    If anyone can help me, please, this is killing me, i have tried restarting and everything, i have not been able to try on a windows computer, but will as soon as i can. What could be wrong?
     
  2. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #2
    I know this reply won't help re the USB cable, but...

    ... assuming the Canon uses an SD card, why not just get a USB card reader and transfer the images that way?

    Something "that works" is better than being frustrated over something that doesn't...
     
  3. stevemurrayphot macrumors newbie

    Joined:
    Mar 16, 2009
    #3
    On Nikon cameras

    there used to be a setting for data transfer where you choose PTP or something similar for the transfer mode or it wouldn't work. Have a look at the instruction manual or try a card reader, it was an obscure setting and not easy to find !
     
  4. poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #4
    Or just use the built-in card reader???

    ----------

    Go in system profile (About this mac>(More Info>) System Report)
    Verify if it is connected or not
     
  5. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #5
    The EOS 50D uses a CF card.
     
  6. someoneoutthere, Oct 10, 2014
    Last edited: Oct 10, 2014

    someoneoutthere macrumors regular

    Joined:
    Jul 27, 2014
    Location:
    Land of... 12,000 Lakes.
    #6
    Click on Spotlight, type Image Capture and launch the app.
    You won't see it as a "device", but you should be able to see and import your pictures through Image Capture.
    Also, check your camera settings. If it is going into Sleep Mode too soon, you can't establish a connection long enough for any of the apps to recognize your device.
    When I connect my Canon DSLR over the USB, the camera's digital panel on the top right hand side reads/flashes "Busy". Double check if you see that.
    Hope it helps,
    Best.

    Edit: "Auto power off" option is under the 4th menu when you press the "menu" button in full auto mode (green rectangle)
    I tried establishing a connection when the power button is at "On" and "Line/Arrow". Connects fine in both cases.
     
  7. Mnowell69 macrumors regular

    Mnowell69

    Joined:
    Jul 4, 2013
    Location:
    Bedford, UK
    #7
    assuming you might need drivers for the mac to recognise the camera (pretty much the same way as the printer)
    With the camera connected try to do a software update. That's how i got my canon printer to work
     
  8. someoneoutthere macrumors regular

    Joined:
    Jul 27, 2014
    Location:
    Land of... 12,000 Lakes.
    #8
    For the printer, yes. For the camera, no. I used to have the same exact camera and it didn't require any sort of installation/update in the current OS.
    Link: http://www.usa.canon.com/cusa/suppo...igital_slr_cameras/eos_50d#DriversAndSoftware
    You might want to do a firmware update your camera first. Let's see if that's going to be of any help.
    EOS 50D, Firmware Version 1.0.9 [Mac OS X] 02/28/12 10.89 MB
    Try that one, download and install the .dmg file and follow the prompts.
    Let us know how it goes.
     

Share This Page