USB connexion does nothing at all

Discussion in 'iPhone Tips, Help and Troubleshooting' started by padmavyuha, Apr 5, 2012.

  1. padmavyuha, Apr 5, 2012
    Last edited: Apr 5, 2012

    padmavyuha macrumors newbie

    Joined:
    Nov 16, 2006
    #1
    Since upgrading to iTunes 10.6 (and then 10.6.1) my iPhone does nothing at all when connected to the USB cable (no matter what USB port I try on my iMac - which is running 10.7.3).

    The phone doesn't recognise it's plugged in either, and doesn't charge. No error messages in the console, nothing to show that the iMac even knows there's anything plugged into the USB port. It worked fine the last time I did a USB sync last month.

    I've tried deleting the AppleMobileDevice.kext file and reinstalling iTunes, but it hasn't helped. Any suggestions?

    (Note: the phone charges fine from the mains adaptor, with either of my USB cables - but neither of them does anything at all on the iMac.)
     
  2. RodThePlod macrumors 6502a

    RodThePlod

    Joined:
    Sep 7, 2005
    Location:
    London
    #2
    Have you checked to see if other USB devices are recognised correctly? For example, a USB mouse or keyboard?

    Do you have an iPod available? - if you connect this, does iTunes recognise and mount it?

    If iTunes/Mac OS recognises the other devices, then try resetting the iPhone.

    Also, as you are on Lion, see if the fix in this thread works: https://discussions.apple.com/thread/3198980?start=0&tstart=0

    Good luck,

    RTP.
     

Share This Page