USB Device Not Showing in Finder or Disk Utility

Discussion in 'iMac' started by sdpgreen, Jul 18, 2013.

  1. sdpgreen macrumors newbie

    Joined:
    Mar 20, 2012
    #1
    Hello all,

    I have a 4gb flash drive mp3 player (uWater G4) that plugs in via USB. It has worked fine for me in the past, but all of the sudden no longer shows in Finder or Disk Utility on my iMac OR MacBook Pro. I went into Terminal and found this message:

    7/18/13 12:58:06.000 PM kernel: USBF: 534.251 The USB Family found a device at port 3 of hub @ 0xfa100000 with a bad USB device descriptor (0xffffffffffffffff, 0x0 )
    7/18/13 12:58:06.000 PM kernel: USBF: 534.253 [0xffffff80122af800] The IOUSBFamily is having trouble enumerating a USB device that has been plugged in. It will keep retrying. (Port 3 of Hub at 0xfa100000)

    I also tried the device on a PC & received a message along the lines of the USB device being "malfunctioning" or "unrecognized" .

    My next thought is to try to find another cord to use, but it's a bit hard to find one because it is USB on one end and the other is a 3.5 mm audio plug.

    I was hoping to be able to get the drive to show in Disk Utility and then reformat it...

    Thanks in advance for your thoughts!!!

    iMac
    OSX 10.7.5
    2.8GHz Intel COre i5
    8GB RAM
     
  2. macthefork macrumors 6502

    Joined:
    Feb 2, 2013
    #2
    Does it play through the earphones? If not, it's probably spent. USB (2) has a 4 wire connection, so that 3.5mm is probably a specialty plug for that player. If you were even able to find another specialty cable for that, it may not fix the problem if it's internal.

    Time to get a new mp3 Player?
     

Share This Page