USB devices fried?

Discussion in 'iMac' started by bluthreunion, May 21, 2012.

  1. bluthreunion macrumors newbie

    Joined:
    May 21, 2012
    #1
    This is driving me crazy and seriously affecting my productivity, so I hope someone here can help...

    A few weeks ago, I moved my 2011 27" iMac from one room to another. Once I got it all set up, I discovered that several of my usb peripherals weren't working. A few flash drives, a wired keyboard, a wired keypad, a wired mouse. They would light up, but they wouldn't actually work. They also wouldn't be recognized in the USB device tree under system info.

    My printers and hard drives, however, usb devices with independent power supplies, worked fine.

    I called Apple Care, they were very nice and sent out a technician to replace my logic board - twice - and then my power supply. After that, the computer would reboot itself every few minutes and it was worse than before. So they sent me a new one. Problem solved, right?

    Wrong.

    I'm typing this on a brand new, factory-direct iMac. I've discovered that all of my original usb devices that i was having problems with now won't work on any other computer either - a PC netbook and an older G4 Powerbook.

    I went out and bought a new keypad and a new flash drive, plugged those in and they work fine. I then dug out of my closet an old keyboard, and that also works fine.

    I've come to conclusion that anything that was plugged into the imac when it was in the other room, and which didn't have its own power supply, is now dead. Was it a usb power surge? Can that even happen? What the hell?

    But here's the most important part. I'm a stop-motion animator, for which i use a Nikon D90 connected to my iMac. The camera is fine, everything works, EXCEPT when I hook it up to my computer via USB, it isn't recognized. It was plugged in with everything else, so I'm afraid that something in it got fried too. I can replace the keyboards and flash drives, but I need my camera to be recognized.

    So, in short - what the hell is going on, and how do I fix it?? Yes, I've tried multiple cables, I've tried restarting, I've tried safe mode, PRAM, turning it on and off, everything. My imac won't recognize my Nikon, and neither will my older powerbook. My PC netbook, however, does.

    3 weeks ago everything was fine, and now this. Any help you could offer is very much appreciated. This is a hell of a mystery for which I can't find an answer on google, and I really need my camera to work!
     
  2. SuperDudeMax, May 21, 2012
    Last edited: May 21, 2012

    SuperDudeMax macrumors newbie

    SuperDudeMax

    Joined:
    Dec 31, 2011
    Location:
    UK
    #2
    This sounds very odd, it's probably best that you get an elicitation to have a look at the plugs in the room.

    For the camera itself, does it work when you take the SD card out and put it into the iMac? Just a thought.
     
  3. Apple fanboy macrumors Core

    Apple fanboy

    Joined:
    Feb 21, 2012
    Location:
    Behind the Lens, UK
    #3
    Have you tried the camera out on another machine?
     
  4. bluthreunion thread starter macrumors newbie

    Joined:
    May 21, 2012
    #4
    Yes, the SD card reader works fine...

    ----------

    I tried it on an older G4 powerbook, where it's not recognized. It is recognized, however, on an EeePC netbook.
     
  5. bluthreunion thread starter macrumors newbie

    Joined:
    May 21, 2012
    #5
    Actually I take that back, it's not recognized on the netbook (i mistook the webcam for the nikon). And my friend just brought over his new powerbook, that doesn't recognize the camera either. It looks like the camera was fried along with everything else. This is so bizarre, I've lost like 8 peripherals because of this, I didn't even know USB hookups could do this.
     

Share This Page