USB Devices Not Working in Windows 7 (Bootcamp)

Discussion in 'Windows, Linux & Others on the Mac' started by EYfromNW, Mar 16, 2013.

  1. EYfromNW macrumors newbie

    Oct 25, 2012
    I finally got 10.8.3 installed this week and setup bootcamp for Windows 7 Pro x64 SP1. SimCity, Battlefiled 3, and Crysis 3 all loaded and look amazing, but I cannot use any USB connected devices!

    I have an Apple Magic Mouse that I use sometimes, but 99% of the time in OSX and always in W7 I want to use a USB connected Microsoft optical mouse. I cannot play first person shooters with the Magic Mouse.

    Upon further research, nothing connected via USB works in WIndows 7, not just the mouse. I have disconnected all other USB devices and booted with only the mouse, but nothing is working. I have connected USB keyboard, 3 different mice, external hard drives, my superdrive, etc. and none of them function on any of the 4 USB ports on the back of my iMac.


    My Configuration

    Late 2012 27" iMac 3.4 GHz i7
    3TB Fusion
    32GB RAM
    NVIDIA 680MX
    OSX 10.8.3
    (Bootcamp) Windows 7 Pro x64 SP1
  2. JonasCalhoun macrumors member

    Aug 26, 2012
    I just installed Bootcamp 5, with Windows 7 x64 on a 2013 rMBP. I've got the exact same issues you describe, no USB devices work at all.

    I've read in a few other forums that there is a specific driver in Device Manager that needs to be uninstalled, but I haven't tried that yet--I'm in the Windows Update->reboot->Update->reboot loop for a few more times while it gets everything together...

    If it fixes it, I'll report back.

  3. JonasCalhoun macrumors member

    Aug 26, 2012
    It worked. Uninstall the driver for the Intel USB 3.0 device, and reboot. All USB devices that I've connected work fine.

  4. EYfromNW thread starter macrumors newbie

    Oct 25, 2012


    I was out of town on business all last week, but I took this simple approach on Sunday and it worked great! Thanks for posting a legitimate response!!!

  5. 100foldstudioIT macrumors newbie

    Sep 5, 2013
    Works on 2012 Mac Mini

    Had exact same symptoms and solution, but took me awhile to figure out how to gain control with Magic Mouse. Here's a little more info for anyone who runs into this.

    I just installed Win7x64 Enterprise in new bootcamp partition on 2012 Mac Mini 2.5Ghz i5, 16GB Ram. Everything went smooth until I ran the Bootcamp Support Software setup which installed Win7 drivers.

    Everything USB went dead. No keyboard. No mouse. Nothing.

    Found this post. I didn't have a magic mouse, eventually borrowed one. You have to reboot to Mac side, connect Magic Mouse (bluetooth), and then reboot to bootcamp partition.

    Windows found magic mouse, installed drivers and in seconds I had mouse control again. Followed this post and went to device manager: start>right click 'Computer'>Manage>Device Manager, expanded USB controllers at bottom, found 'Intel(R) USB 3.0 eXtensible Host Controller', right clicked and uninstalled.

    After a restart and the windows update hoopla to reinstall the correct drivers, USB came back to life.

    Thanks to those who posted here. I was at a loss.

Share This Page