USB devices won't connect to computer?

Discussion in 'MacBook Air' started by whashgood11, Sep 6, 2011.

  1. whashgood11 macrumors newbie

    Joined:
    Sep 6, 2011
    #1
    I just bought a new 13 in., 128 GB MacBook Air about a month ago for college. It has performed fine in general for me, however it doesn't seem to let me connect anything to either of the USB drives. At this point, I have tried connecting a printer through a USB printer cable (which works, mind you, with my roommate's computer), and a mouse with new batteries that worked on a different computer as well. In both situations, an error message immediately comes up saying "Because a USB device was drawing too much power from your computer, one or more of your USB devices has been disabled," and it fails to connect.

    Can anyone help me with this? Thanks
     
  2. yusukeaoki macrumors 68030

    yusukeaoki

    Joined:
    Mar 22, 2011
    Location:
    Tokyo, Japan
    #2
    Is your MBA fully charged?
    If it is, try it with the Magsafe connected.
    If it still doesnt work Id say logic board failure.

    Call Apple
     
  3. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #3
    If it's still giving you the same message after rebooting then, yeah, it sounds like it's borked hardware.
     
  4. Peter Harrison macrumors 6502a

    Peter Harrison

    Joined:
    Dec 24, 2009
    Location:
    UK
    #4
    I have a different problem. Every USB device I've tried so far is working, but not a mouse. I'm not getting an error message like the OP did. The mouse lights up (drawing power), but simply doesn't work. It doesn't move the cursor. No obvious reason in System Preferences why it wouldn't be. Same mouse works on other Macs. Trackpad is preferred option anyway, but it's annoying as I wanted to use the mouse for some games.

    Any ideas? Have done the obvious things like restarting the Air, trying different USB ports, checked everything in System Preferences.
     
  5. adonis3k macrumors 6502

    Joined:
    Apr 15, 2012
    #5
    Did you get this working? Im having the same problem, cant connect USB mouse on either side of the MBA ports even though the optical light comes on but no cursor movement! :confused:
     
  6. sinoue macrumors newbie

    Joined:
    Feb 16, 2011
    Location:
    Silicon Valley
    #6
    check USB cable

    Longshot, but worth mentioning:

    Make sure you are trying different USB cables. Some USB cables that come with various devices are for charging only, and don't have any ability to do data sync.
     

Share This Page