USB drawing too much power - help!

Discussion in 'Mac Basics and Help' started by lolalittlekamp, Apr 2, 2012.

  1. lolalittlekamp macrumors newbie

    Mar 31, 2012

    I recently tried to plug my printer into one of my macbook pro usb ports and I'm getting a message that reads that the USB is drawing too much power and the port will be deactivated. I'm very confused! I've used the printer before on the computer with no problem. I changed the usb cables out, I went and bought a self powered mutli usb hub.. that didnt work. HELP!
  2. ashevillelynne macrumors newbie

    Apr 10, 2012
    Same problem

    My new macpro laptop is doing the same thing - I get the message when I just plug in the cord even without a camera attached. Did you find out whY?
  3. chown33 macrumors 604

    Aug 9, 2009
    Sailing beyond the sunset
    In this case, I would suspect a defective USB cable (what you call the "cord"), or a defective connector.

    A plain USB cable with nothing attached at the other end shouldn't consume any power at all. It's just wires. If there's a short circuit in the cable, then that's a serious problem, and will lead to the error message.

    The most likely solution is to use a different cable. If that one fails, too, then maybe the problem is in the computer's USB connector. You'd have to take it in for service to know for sure. If you do that, you should also take the cables that are failing, because you might just have multiple defective cables.
  4. Fishrrman macrumors G5


    Feb 20, 2009
    Is the printer "USB powered", or, does it have it's own power source?

    For reasons known only to Apple, many (not all, but most) Macs do not supply enough USB "bus power" to support some external USB devices. Typically, if you already have a USB device or two connected (example: keyboard and mouse) and attempt to plug in -another- device (that requires USB power), you may get an alert that the USB bus cannot supply power to the device (and has been "deactivated", as said the message you received).

    What's happened is that you tried to connect a device (or devices) that exceeded the aggregate ability of the Apple USB bus to supply power to all of them.

    If the printer you have -is- "USB powered", and -if- it has an external power supply block, try powering it up using the power block and then connecting to the Mac. That may help.
  5. McGiord macrumors 601


    Oct 5, 2003
    Dark Castle
    My Late 2008 MacBook Pro with Lion, is giving me the same error message, when plugging in the iPhone USB cable only. I will check with other cables.

  6. Greavsie macrumors newbie

    Oct 8, 2011
    Just had exactly this problem with a Blumax GPS device on my new MacBook Pro. Tried it on my MacPro. Same problem. Tried it with a powered hub. Same problem. Tried a different USB cable from the one supplied, worked perfectly. So the supplied USB cable has gone in the bin.

    I reckon that all USB cables are (in theory) equal, but some are more equal than others.
  7. chiguimania macrumors member


    Dec 29, 2008

Share This Page