USB drive External can not be formatted

Discussion in 'Mac Accessories' started by mashinhead, Oct 26, 2006.

  1. mashinhead macrumors 68030

    Oct 7, 2003
    I bought a new hd for my macbook when i first got it. I had the original drive which i didn't use for a while, and recently got a housing for it to be external. It connects via USB and powers via usb no external adapter. It mounts as the original 'macintosh hd' because it has os x installed but when i try to reformatt it in disk utility i always get the same error, drive can not unmount. i can't even repair permissions.
  2. jeremy.king macrumors 603


    Jul 23, 2002
    Fuquay Varina, NC
    You can only repair permissions on the boot drive.

    So are the two drives named the same thing? If so, try to rename the external drive and then retry formatting.
  3. Eidorian macrumors Penryn


    Mar 23, 2005
    OS X handles that chance. I've had two drives named "Macintosh HD" on a single machine. The non-boot drive changed itself to some random string of characters for its name.

    Still, have you tried using a Live CD or another computer to format it?

Share This Page