USB drive lost

Discussion in 'Mac Basics and Help' started by Hip79, Jan 31, 2008.

  1. Hip79 macrumors newbie

    Joined:
    Jan 31, 2008
    #1
    I have WD My Book Pro attached to my iBook. Yesterday I launched an application (Acquisition) that usually downloads to My Book but it wasn't on. I noticed it after the download was complete but I couldn't find the download anywhere. So I searched it with File Buddy and it was located on the local hard drive in path

    /Volumes/<name of the external hard drive>/<name of the usual download folder>

    Acquisition created the subfolders and File Buddy made the /Volumes folder visible. When I put the My Book back on after this, iBook no longer found it and hasn't found since. It doesn't show up even in Disk Utility (is it called that? I have a finnish OS X :) Thru firewire the hard drive shows normally but since there's only one fw connection, I need it to work thru USB.

    Help needed.
     
  2. GavinTing macrumors 6502

    GavinTing

    Joined:
    Sep 4, 2007
    Location:
    Singapore!
    #2
    Uhh, did you try the USB on another computer? Or try another USB cable?
     
  3. Hip79 thread starter macrumors newbie

    Joined:
    Jan 31, 2008
    #3
    Cable must be fine because the light indicates that My Book responses to connection.

    I tried to install My Book on my old PC running XP but failed. It finds a new USB device but cannot find the driver for it. I'm not sure whether or not these problems are related.
     
  4. Mr.Texor macrumors regular

    Joined:
    Apr 20, 2007
    #4
    This is what I would do.

    Go to /Volumes
    and delete (or move) the folder and all the contents in:
    /Volumes/<name of the external hard drive>

    Do this while the usb drive is unplugged.

    After "/Volumes/<name of the external hard drive>" is gone. Plug the usb drive.
    See if that works.
     
  5. Hip79 thread starter macrumors newbie

    Joined:
    Jan 31, 2008
  6. Mr.Texor macrumors regular

    Joined:
    Apr 20, 2007
    #6
    Sorry it didnt help :(
    Try renaming the disk in another computer (if you have access to one) and see if that works.
     
  7. Hip79 thread starter macrumors newbie

    Joined:
    Jan 31, 2008
    #7
    I renamed the drive via firewire but unfortunately it didn't work either.
     

Share This Page