usb drive not recognized in single user mode

Discussion in 'MacBook' started by mcarilli, Sep 13, 2009.

  1. mcarilli macrumors newbie

    Joined:
    May 20, 2009
    #1
    Hi!
    The title pretty much says it all: When booted in single user mode, I can't get my machine to recognize the USB drive. Here's what I did:
    1. inserted usb stick (memorex 4GB traveldrive, msdos filesystem)
    2. booted in single user mode (cmd+s after powering on)
    3. mount -uw /
    3. looked for usb device in /dev
    4. ...it's not there! The USB drive shows up as /dev/disk1s1 after an ordinary boot, but in single user mode it's nowhere to be found. It's not just a name issue either: the list of devices that appear in /dev in single user mode is the same whether or not the USB stick is plugged in.

    Even more confusingly, out of the 10(?) times I tried this it worked twice: /dev/disk1s1 actually appeared.
    mkdir /mydirectory; mount -w -t msdos /dev/disk1s1 /mydirectory
    worked fine, and I was able to read/write from the stick as usual. I have no idea what I did differently those two times.

    Does anybody know what's going on? I've got a MacBook2,1 running vanilla Leopard.

    Thanks for taking the time to read this, and thanks in advance for your help :)
     
  2. mcarilli thread starter macrumors newbie

    Joined:
    May 20, 2009
    #2
    Just downloaded the latest firmware update, and the USB drive appears consistently now.

    Sorry for the double post; just wanted to make sure nobody besides me wastes their time on this.
     

Share This Page