USB Drive Problem

Discussion in 'iMac' started by apsterling, Jul 13, 2008.

  1. apsterling macrumors 6502a

    apsterling

    Joined:
    Nov 24, 2007
    #1
    I have a USB 2.0 HD that I've used and have a number of relatively important files on, that after updating, no longer shows up anywhere in OS X.

    Disk Utility doesn't show the drive, and therefore won't mount it. On my mom's Windows XP computer it worked fine, no problems.

    I repaired disk permissions on my startup disk, no dice.

    Any suggestions (hopefully not involving reinstalling OS X, as I now have no way to backup)
     
  2. CanadaRAM macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #2
    You're going to have to give us more information.

    What update did you do?
    If it shows up on the PC machine, chances are it is not formatted for Macintosh HFS+ -- so how is the drive formatted?
     
  3. CWallace macrumors 601

    CWallace

    Joined:
    Aug 17, 2007
    Location:
    Seattle, WA
    #3
    Copy the files off to your Windows machine, reformat the drive and copy them back and see if the Mac can read them.
     
  4. mustang_dvs macrumors 6502a

    mustang_dvs

    Joined:
    Feb 9, 2003
    Location:
    Durham, NC
    #4
    Here's a troubleshooting list. I'm assuming that you don't have access to TechTool, DiskWarrior, Drive Genius or Norton Utilities (on the PC). If the step doesn't fix the problem, move down the list. It's not a bad idea to backup the data onto the PC first.

    1. Try a different USB cable (it know it sounds silly, but try it).
    2. Disconnect the drive, reboot the Mac and plug it in, if it doesn't show up, open Terminal.app and type ls -la /Volumes. If the drive name shows up in the list, unplug the drive, go into the Finder's Go menu and choose "Go to Folder..." type /Volumes, and hit return. If, after disconnecting the drive, there's a folder in it with the drive's name, throw it in the trash and empty it, reboot and reconnect the drive.
    3. Copy the files from the drive on to the XP machine, plug it into the Mac and open Disk Utility. If the device is listed but there is no volume/partition, reformat it (in Windows, or as FAT-32 in OS X -- assuming that you don't have a 3rd party HFS+ driver on the Windows XP box and that the drive is FAT-32 formatted in the first place) and re-copy the files onto it.
     
  5. apsterling thread starter macrumors 6502a

    apsterling

    Joined:
    Nov 24, 2007
    #5
    Mustang, yes I've tried other cables, to no success.
    The drive didn't show up via the ls -la method, and I've backed it up to a separate drive. I'm not sure if I'll reformat or not- the drive isn't worth much to me.

    The Formatting is FAT32.
     

Share This Page