USB Drive undetected on MBP 13" 2015

Discussion in 'Mac Accessories' started by flju, Apr 19, 2015.

  1. flju macrumors newbie

    Joined:
    Apr 19, 2015
    #1
    Hi,

    I've got an Integral 32GB Fusion USB 3 Flash Drive that is well recognized on every PC and my old MBA, but can't be mounted on my new MBP Retina 13" 2015.

    Some details :
    - Others USB 3 Flash Drive work fine on my MBP
    - The usb drive doesn't appear in Disk Utility
    - I've got Paragon NTFS to be able to mount NTFS drive, anyway i've tried to format my flash drive in HFS+ and it doesn't solve the problem
    - it seems my MBP doesn't try to mount the USB key, as if it was not put into the USB port : if i remove the USB key from my MPB and put it on an other computer, I do not have an error message telling me that I removed my key inappropriately

    Do you have experienced similar problems on MBP Retina, is there a way to fix it ?

    Thanx !
     
  2. JTToft macrumors 68040

    Joined:
    Apr 27, 2010
    Location:
    Aarhus, Denmark
    #2
    If it doesn't appear in Disk Utility, it doesn't just not mount, but your MBP doesn't know that a USB device as been plugged in at all. Which is strange.

    Try running this command in Terminal to see if it shows up there:
    Code:
    diskutil list
    Can you use other disks via the USB port in question?
     
  3. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #3
    If only that one USB flash drive is not working, and only in one MBPro, then there's not much you can do, other than remembering that flash drive doesn't work in your new MBPro.
    Problem is likely only that flash drive. Some newer flash drives might have a warranty, so you could try replacing it, or just use a different flash drive.

    My experience: Some flash drives that are used a lot (lots of reads and writes, often erased completely, and filled up again), tend to get less and less reliable as it is used. Currently, the worst offenders (for me) are the "budget/cheap" models that are sold as USB 3.0. - But, I may just have hit an unlucky batch.
     
  4. flju thread starter macrumors newbie

    Joined:
    Apr 19, 2015
    #4
    It doesn't appear with the diskutil command... on any of the two USB ports :(
     
  5. Ray2 macrumors 6502a

    Joined:
    Jul 8, 2014
    #5
    Not an uncommon event with my USB 3 drives. Won't mount after repeated unplugs and replug-ins, does not appear in DU. A restart with the drive plugged in always does the trick with both my '15 rMBP and my wife's '14 MBA. Sort of a pain but I'm down to one bus driven USB drive and I can live with it.

    If you don't need the speed, get a USB 2 coupler and run the drive in USB 2 mode. I find they will always mount like this.
     
  6. flju thread starter macrumors newbie

    Joined:
    Apr 19, 2015
    #6
    Thanx for the experience feedback !
     
  7. juelzro macrumors newbie

    Joined:
    Apr 19, 2015
    Location:
    San Francisco
    #7
    I have a similar problem (also have the rMB 2015), but my external HD is USB 2.0. I'm able to see it through the USB section of SYSTEM INFORMATION, but can't see it through disk utility. I've even tried resetting PRAM and SMC, and it's still inaccessible. It works fine on my 2008 MB though :confused:
     
  8. Ray2 macrumors 6502a

    Joined:
    Jul 8, 2014
    #8
    Between my wife and I and 2 homes, we have 2 new MacBook's and 3 older USB 2 desktops. Both of the newer machines have issues with USB 3 while neither of the older machines display any issues at all.

    Don't sweat the core functionality lapses, we now have emoji's.
     

Share This Page