iPhone USB error in redsn0w when pwning DFU

Discussion in 'Jailbreaks and iOS Hacks' started by fophillips, Feb 27, 2013.

  1. fophillips, Feb 27, 2013
    Last edited: Feb 27, 2013

    fophillips macrumors newbie

    Joined:
    Feb 27, 2013
    #1
    Hi,

    I have just inherited an iPhone 3G and I am trying to install the pwned DFU from redsn0w. I have successfully entered DFU mode following the instructions, but then I get a "USB communication error" but the iPhone is recognised as being connected on the first page of redsn0w. I have tried restarting my computer, changing USB port, restarting the iPhone and reentering DFU mode. I have done this on two separate computers, the first running OS X 10.8.2 and the second with Windows 7, both with the latest iTunes installed but not running.

    Any ideas?

    Thanks!
     
  2. Alterbreaker, Apr 18, 2013
    Last edited: Apr 18, 2013

    Alterbreaker macrumors newbie

    Joined:
    Apr 18, 2013
    #2
    Here's what fixed the communication error for me!

    This approach http://www.electronmedia.in/wp/archives/1157#comment-278 basically worked for me but with some minor differences. I too was experiencing the horrible usb communication error every time I tried to use redsn0w to enter pwned DFU mode. I have an iPhone 3g and was trying to use whited00r 6.0 Normal. Although all of these steps might night be necessary, here are the steps that fixed the problem for me:
    (For all of these steps I had my iphone connected and on and itunes running the entire time)
    - downloaded redsn0w 0.9.12b1 (might try with most recent version first if you already have it.
    - clicked on "select IPSW" and then browsed to my copy of the whited00r .ipsw and opened it. Unfortunately I got an error message saying that redsn0w doesn't support it (hence this step might not be necessay, but I wanted to give you every detail in case it makes a difference).
    - clicked on the pwned DFU option in redsn0w.....and after hours of trying - Voilà!!! the program said my phone was in a pwned DFU mode in about 2 seconds and without me having to push any buttons. Weird right? Before that my phone was simply turned on and connected in the normal state.
    - after that, installing whited00r was just a matter of going to iTunes and doing option+click on the restore button and selecting the .ipsw file. Now my phone is faster and better than ever!
     

Share This Page