USB external drive not recognized

Discussion in 'Mac Accessories' started by Erch, Dec 27, 2006.

  1. Erch macrumors newbie

    Dec 27, 2006
    I'm having some troubles with an external enclosure and my sister's new imac.

    The enclosure I'm using is a Tao Tec 2500 (2.5" drive) IDE --> USB device with the Y-cable. The drive has been formatted to NTFS and has some files on it. As far as I can tell though the version of OSX the new imac is running should support read capability with the file system though.

    The computer is a latest generation imac (purchased about 12/20/2006) and running a new revision of OSX (about I believe).

    My problem seems to be the computer simply does not recognize the drive. Disk utility doesn't see it nor the usb manager in system tools. The LED indicator on the drive indicates that it's receiving power and I've tried swapping the usb ports around just to be sure I don't have a bumed port. It simply seems like OSX just doesn't know the drive's there.

    Any help or advice in the right direction appreciated.
  2. Cloudgazer macrumors 6502


    Apr 22, 2005
    I had the same problem yesterday.

    I needed some files on my bosses portable Lacie drive.
    I plugged it into my pbook.
    A little green light on the Lacie started flashing and it started beeping.

    And that was it.

    I'm thinking that that Lacie was formatted on a WinXP machine might be the problem. But don't really know.
  3. Erch thread starter macrumors newbie

    Dec 27, 2006
    Well yes, one of the first issues I thought of being a PC user is that the NTFS formatted drive wouldn't be recognized on my sister's mac. But I checked the version history of OSX on her computer and as far as I can tell it should have NTFS read support at the very least.
  4. Reflow macrumors 68000


    Mar 30, 2005
    Have you tried to reboot the iMac with the drive still plugged in? I had a similar problem with my QS. A simple reboot worked
  5. chasemac macrumors 6502a


    Jan 30, 2005
    In a house.
    Have you tried plugging it back into your sisters Mac to double check?
  6. 4JNA macrumors 68000


    Feb 8, 2006
    looking for trash files
    you didn't specifically say which usb ports so... plug the drive into the actual usb port, not a hub, or the port on the keyboard, or whatever. the actual computer usb port on the back of the iMac.

    also wonder if the drive has a ac wall adapter that you can use, or is the bus powered only? have a drive or two that will actually light up, spin up, and still not mount unless they have the ac adapter plugged in... not quite enough power for logic and drive is my guess. and it should still mount with NTFS, and support read but not write.

    as a last thought, i also have one older 2.5" usb 1.1 enclosure that is just not mac compatible due to the chipset used. will not mount no matter what. this may be one of those kinda problems. check the specs to see if it is being listed as mac compatible. best of luck.
  7. Erch thread starter macrumors newbie

    Dec 27, 2006
    First off thanks for the replies guys.

    Yeah, initially I had plugged it into the usb port on keyboard but common computer voodoo paranoia told me to try different ports.

  8. Erch thread starter macrumors newbie

    Dec 27, 2006
    Went out and got a 5v ac adapter. Drive got power from it but still isn't spinning up and not recognized by the mac.
  9. pknz macrumors 68020


    Mar 22, 2005
    Is it recognised by other Macs/PCs? Could the drive be dead?

    MR does support multiple quotes, but you need to close the quote tag with a [/quote]
  10. Om bholenath macrumors newbie

    Nov 23, 2009
    Mac won't read USB

    My mac won't recognise or read any usb i plug in, not even my ipod. I have checked the preferences in finder and the external drives have been ticked. Anyone know what the problem might be? Thanks guys.

Share This Page