USB External Error

Discussion in 'macOS' started by baucke, Oct 6, 2007.

  1. baucke macrumors newbie

    Joined:
    Oct 6, 2007
    #1
    Hi, I have a "white-lable" hard drive I've been using successfully for almost a year with a USB connection.

    Recently I was unable to access any of the data and the only item in the viewer function was a "USBC" with a bizarre icon. I figured this would be the most appropriate place if anyone has seen this error before, or could refer me to another forum I might be able to ask to see if I can recover the hard drive. I used the disk-repair program, and it froze, than when I formatted it seemed to work fine, and returned to this error shortly there after, probably two or three times after accessing the data.

    Thanks!

    [​IMG]
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    It sounds like the drive is dead, but do you have another cable with which to test it? :)
     
  3. baucke thread starter macrumors newbie

    Joined:
    Oct 6, 2007
    #3
    yeah...Ill give that a shot in another tower with SATA support. Shoot. Does anyone know if 'white label' is just generic or refurb?
     
  4. Kalel macrumors newbie

    Joined:
    Jan 20, 2008
    #4
    i have same problem can anyone help?

    Hi i have exactly the same problem with a freecom toughdrive. i get the same symbol.

    There is no option to change the cable as its moulded on. But the wierd thing is that when i check on the system profiler it reads the drive and tells me how full it is. So not sure if it is dead? (whatever that means) also the drive power light is on when i plug in the usb cable and it mounts just get funny icon.

    anyone any ideas. i have a file on there i really need this week

    thanks
     

Share This Page