USB Flash Drive is "unknown device" when Windows 7 boots

Discussion in 'Windows, Linux & Others on the Mac' started by Durex, Sep 24, 2009.

  1. Durex macrumors member

    Sep 24, 2009
    Hi Everyone!

    This is my first post to MacRumors. I've searched the forums and Google for help on my problem but didn't find a solution. I hope the experts here can help me :)

    I've just installed Windows 7 64-bit via bootcamp on my new Mac Pro running Snow Leopard. The Windows 7 install went fine, and the 64-bit drivers from Apples Snow Leopard DVD installed without any problems.

    Everything seems to be working fine. I plugged in a USB flash drive (FAT32 format) while running Windows 7 and it was detected okay. I copied some files off it and at some point rebooted the Mac Pro leaving the USB flash drive plugged in.

    When Windows 7 restarted I discovered an "unknown device" listed under "USB controllers" in Windows' Device Manager. I noticed that the USB flash key was not visible in Windows Explorer (and its activity light was not on). I removed the flash drive, and the "unknown device" disappeared from Device Manager. I could then plug the USB flash drive back in and it was properly recognized.

    The problem seems to be that if Windows boots with a USB harddrive (or at least flash drive) connected, it is not properly detected by Windows and I need to unplug and replug it to make it work.

    Does anyone have comments on this? Any news or ideas would be great to try and resolve the problem.

  2. Stridder44 macrumors 68040


    Mar 24, 2003
    Huh, sounds like a pretty big bug to me. I'll post back and see if I get similar results.
  3. Durex thread starter macrumors member

    Sep 24, 2009
    Problem seems limted to FLASH drives, not HDDs

    Thanks for the reply Stridder44! I'll look forward to what you find out. In the mean time I've done some tests:

    1. Plugged same USB flash drive (FAT32 format) into HP laptop running Windows 7. No problems experienced.

    2. Connected an external USB hard drive (NTFS format) to the Mac Pro while running Windows 7. After Windows installed required drivers, functions perfectly. I rebooted Windows 7 and the external USB HDD is detected correctly.

    3. I formatted the USB flash drive as NTFS format and repeated the test on the Mac Pro. If the flash drive is left plugged in and the Mac Pro is rebooted, the flash drive is not correctly detected. The flash drive appears as an "Unknown device" in Windows' Control Panel. Upon removing and plugging back in the flash drive it is working again as expected.

    The tests seem to conclude that Windows 7 is not the problem, and it does not appear to be FAT32/NTFS related. Given that the external HDD works, it seems the problem is limited to USB FLASH MEMORY drives.

    The particular USB flash drive I have been testing with so far is a SanDisk U3 USB Cruzer Micro 2GB.

    Finally, I tried a Kingston 4GB USB flash drive (FAT32) and it WORKED as expected! Hooray!

    So, there seems to be some issues with some flash drives...quite odd...

    In the end, this is not something I consider much of a problem, since I'd rarely leave a flash disk plugged in for long. I was somewhat alarmed at the "unknown device" in Device Manager and I'm glad it turned out to be something trivial (I spent a while deleting and reinstalling drivers in Windows 7 before I realized it was the flash drive I forgot about!)

    Cheers folks!
  4. wesrk macrumors 6502a

    Nov 4, 2007
    I had a similar problem, but not exactly the same.
    I was using my flash drive fine, then in OSX (snow leopard) I formatted it as Fat32, now whenever I try to use it under Win 7 and XP, they both want to format it again and only as a 200 mb partition.
    Back on OSX it's normal, but I can't use it with my windows machine, which is what I wanted.

    edit: Maybe this will work for you too,

    Malcolm Rayfield

    Select the drive in Disk Utility (all the way at the left, not the volume indented beneath it), and click the "Partition" tab. Set "Volume Scheme" to "1 Partition". Click the "Options" button and select "Master Boot Record" and click "OK". Set "Format" to "MS-DOS (FAT)". Set a "Name" and click "Apply".

Share This Page