USB flash drive occasionally won't mount

Discussion in 'Mac Basics and Help' started by mac_in_tosh, Jun 2, 2019.

  1. mac_in_tosh macrumors 6502

    mac_in_tosh

    Joined:
    Nov 6, 2016
    Location:
    Earth
    #1
    I have an encrypted USB flash drive that I use often. Every once in a (great) while, it won't mount when I insert it. Rebooting seems to fix the issue but here's what's puzzling - when it won't mount, if I launch Disk Utility it shows the drive and if I click on the mount icon it will mount it. So what would cause the OS to not mount the drive if it knows it is there?
     
  2. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    Location:
    betwixt
    #2
    Does the non-mounting behavior occur only on a specific computer? If so, might it also be a specific USB socket?

    USB connectors do wear out, and an intermittent connection can lead to infrequent failures.
     
  3. mac_in_tosh, Jun 2, 2019
    Last edited: Jun 2, 2019

    mac_in_tosh thread starter macrumors 6502

    mac_in_tosh

    Joined:
    Nov 6, 2016
    Location:
    Earth
    #3
    It's just one computer and in the past I believe I have tried a different USB port. In any case, rebooting always seems to fix the problem so my inclination is that it's more of a software than hardware issue. And as I mentioned, the OS knows the drive is there and I can manually mount it using Disk Utility, but the OS won't automatically mount it.

    By the way, it's an encrypted flash drive so when I say "mount" I mean put up the window asking for the password. I wonder if the encryption has something to do with the issue.
     
  4. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #4
    You might start using a DIFFERENT flash drive for the encrypted storage.

    Then take the problem drive, erase it, and use it for UNencrypted stuff.

    Flash drives can just be flaky and unpredictable some times...
     
  5. NoBoMac macrumors 68020

    NoBoMac

    Joined:
    Jul 1, 2014
    #5
    What OS version? There is a thread for Mojave where some people are seeing this with encrypted USB drives (flash, spinners, SSD). Hit/miss of it occurring it seems, as I have yet to run into this with my encrypted media.
     
  6. mac_in_tosh thread starter macrumors 6502

    mac_in_tosh

    Joined:
    Nov 6, 2016
    Location:
    Earth
    #6
    When this happened most recently, another encrypted flash drive also did not mount.

    High Sierra, 10.13.6.
     

Share This Page

5 June 2, 2019