USB flash drive stopped being recognized

Discussion in 'Mac Basics and Help' started by mattbatt, Sep 28, 2007.

  1. mattbatt macrumors member

    Joined:
    Sep 7, 2006
    Location:
    Placerville
    #1
    Running a dual G5, with 10.4.10

    My problem is that my SanDisk Cruzier Titanium 512 now is unrecognized when inserted after working for 3 years and a few months after upgrading to 10.4.10 (read from another post here, that "the 10.4.10 has been known to kill external USB harddrives").

    The cruzier is formatted MS-Dos FAT32, windows sees it as well as an older G4, 10.3.9 machine.

    I recently loaded the Maxtor 1TB external firewire drive, then had problems:

    First, I noticed that the icon changed when I inserted the cruzier titanium: instead of a usb white icon, it now appears the same as an external drive icon. Then it stopped working altogether. I'd restart, with it in, then it would work, now nothing, even without the external drive powered on. Says it is unrecognizable and to initialize.

    Disk Utilities recognizes it, but wont mount the sub disk, says an error, need to be reformatted. Before the 1TB drive, I installed an internal hitachi 500 GB drive but everything seemed ok.

    I'm just curious as to all this.
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    I had an issue similar to this, but instead of Mac OS X failing to recognize the drive and Windows succeeding, it was the exact opposite. Updating the drive's firmware fixed it. You might want to give that a try.
     
  3. mattbatt thread starter macrumors member

    Joined:
    Sep 7, 2006
    Location:
    Placerville
    #3
    The Maxtor 1TB drive, or the flash drive? Thanks!
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    The Maxtor 1TB definitely, but also look for firmware for the flash drive while you're at it. It might help.
     
  5. mattbatt thread starter macrumors member

    Joined:
    Sep 7, 2006
    Location:
    Placerville
    #5
    my titanium is pre U3 drivers, so no updates there
     

Share This Page