USB flash drives and Mac OSX 10.5.6.

Discussion in 'MacBook' started by kenn, Feb 17, 2009.

  1. kenn macrumors member

    Joined:
    Jan 10, 2009
    #1
    A Verbatim Store 'N' Go 4GB is not even recognised by Mac OSX 10.5.6 when plugged in. Is this to be expected and can the Mac OS be configured to recognice it?
     
  2. drlunanerd macrumors 65816

    drlunanerd

    Joined:
    Feb 14, 2004
    Location:
    UK
    #2
    Does it work OK under Windows? It might be something to do with Verbatim's V-Safe 100 security application?

    Load Disk Utility and see if it shows up. You could try re-partitioning it with MBR and then formatting as FAT32, that's if you've no data on it you want to keep.
     
  3. kenn thread starter macrumors member

    Joined:
    Jan 10, 2009
    #3
    Yes. It does work under Windows. When I'm on Windows Vista windows says it's already FAT32. I then tried a Sandisk 2GB cruzer flash drive on my Mac OS X 10.5.6 leopard and that wasn't recognized either. Then I brought the Sandisk flash drive to a local computer store today to see if it was recognized on their Macs. The Sandisk showed up in disk utility on their Mac but not on mine (same OS). I also downloaded and installed a USB driver package from the Mac Developers site on the web. What can the problem be? Am I still missing drivers? I don't like the same two OS, the one in the store and mine behave so differently with something as common as flash drives.
     
  4. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #4
    I've never had a problem with any flash drive on my Unibody running 10.5.6.

    Are you sure your USB ports are functioning properly to begin with?
     
  5. kenn thread starter macrumors member

    Joined:
    Jan 10, 2009
    #5
    I really don't know. The flash drives light up though. Will now try to check system logs. Weird man!
     
  6. OnceBitten macrumors member

    Joined:
    Feb 18, 2009
  7. uicandrew macrumors 6502a

    Joined:
    Jan 19, 2006
    #7
    1. try hardware test (get your system disc, it has instructions on the disc)

    2. it could be your usb port. my friend had similar problems with his usb port on his MBP 2nd revision. he had 3 usb ports on his and it worked fine on the other 2
     
  8. lozzy1234567890 macrumors member

    Joined:
    Jul 9, 2008
    #8
    it should work, i have the exact same usb stick as you, a blue verbatim 4 gig store 'n go stick, and i can use them with windows and my precious macbook :D
     
  9. hodgeheg macrumors regular

    Joined:
    Dec 7, 2008
    #9
    I had a similar issue with my MacBook Air whereby external USB flash and hard drives were clearly getting some power but not working, and my superdrive wasn't working at all. I do not know if the same issue may occur on other machines.

    Basically resetting the Power Mangement Unit fixed it. This was done by (while the machine is off) holding down left shift, ctrl and option, then pressing the power button once while they're held down. This make no sign that it's done anything. Then wait 5 seconds and turn on. This fixed everything and it has stayed fixed since.
     
  10. kenn thread starter macrumors member

    Joined:
    Jan 10, 2009
    #10
    Problem solved.

    Both the Verbatim and the Sandisk is now working properly. I played around with the USBprober and suddenly bingo. Have no idea what happened in detail, but the USBprober utility was it.
     
  11. kenn thread starter macrumors member

    Joined:
    Jan 10, 2009
    #11
    Still, when I unplug a USB drive (drag it to the recycle bin) and put it back in right after, it is not recognised. I have to restart the OS to have it recognised. Anyone with a suggestion as to how I make it automatic without having to restart the OS?
     
  12. danvan21 macrumors regular

    Joined:
    Mar 27, 2008
    #12
    similar issue. i had an XP formate drive so i wiped it and formatted it for os x and then went to my pc and put the file back on it and it was recognized by both my mac and pc
     
  13. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #13
    Wait a little bit/switch which port you use.

    Maybe don't unplug and replug it right away? Just leave it in.
     

Share This Page