USB hubs not working during sleep?

Discussion in 'OS X El Capitan (10.11)' started by kriista1234, Oct 6, 2015.

  1. kriista1234 macrumors regular

    Joined:
    Jan 12, 2008
    #1
    Since upgrading to El Cap my mid 2011 Mac Mini doesn't keep power going to the USB ports when it goes to sleep. I've noticed my phone isn't charged when I get up in the morning, and this was never the case with every OS I've had before (same hardware setup for years).

    What's especially weird is that my hub is powered, but I guess if it doesn't see a USB signal or something, it stops working.
     
  2. Mikey86uk macrumors 6502

    Joined:
    Jul 3, 2010
    Location:
    England
    #2
    Having the same issue with my 27" iMac.

    Annoying really as i always left my iPhone to charge overnight.

    Hope they fix the issue.
     
  3. kriista1234 thread starter macrumors regular

    Joined:
    Jan 12, 2008
    #3
    Good that I'm not the only one experiencing it, so it's likely something with the OS.

    Yeah, not a great situation waking up to a phone at 60% or whatever it is.
     
  4. hallux macrumors 68020

    hallux

    Joined:
    Apr 25, 2012
    #4
    Sounds like more of a firmware issue. I noticed my mid-2012 Mini has a firmware update pending (I haven't done El Cap on it yet). I wonder if there's something there. TYPICALLY, an OS wouldn't trigger the USB ports to be awake or asleep, it's a suspend/sleep state in the firmware.
     
  5. kriista1234 thread starter macrumors regular

    Joined:
    Jan 12, 2008
    #5
    Just checked and there's no firmware showing in the updates panel.

    I've had this USB hub for about 8 years (it's USB1) and have gone through a couple of OSs with this computer too, and never had this issue before El Cap.
     
  6. the bug macrumors member

    the bug

    Joined:
    Feb 21, 2014
    #6
    Good, it's not just me either.
    I have been having trouble with my Belkin 4 port USB 2.0 hub since upgrading to ElCap.
    I thought it may have had to do with running on an unsupported 1,1 flashed to a 2,1 , but apparently not.
    When waking from sleep mine would get stuck in an endless loop of these errors filling up the console, they would keep counting up every 100 ms in an endless loop :
    Code:
    PM kernel[0]: 000002.196615 AppleUSBEHCIPort@fd400000: AppleUSBHostPort::resetGated: retrying enumeration in 100 ms
    - Jay
     
  7. hallux macrumors 68020

    hallux

    Joined:
    Apr 25, 2012
    #7
    That's because you may have installed the FW update already.
     
  8. neliason macrumors member

    Joined:
    Oct 1, 2015
    #8
    I had this problem. In my case my iPhone would not charge when plugged directly into the iMac USB port when the iMac was asleep. Even after the iMac woke up it would not charge. I unplugged from the phone and plugged back in, while the iMac was awake, and it did charge.

    I rebooted and the problem seems to have resolved itself for now. But I've also had problems with USB hard drives randomly disconnecting. There seems to be some issues with USB in El Capitan.
     
  9. Mikey86uk macrumors 6502

    Joined:
    Jul 3, 2010
    Location:
    England
    #9
    I also rebooted and it has fixed it (For now)

    Odd.
     
  10. mpainesyd macrumors 6502

    mpainesyd

    Joined:
    Nov 29, 2008
    Location:
    Sydney, Australia
    #10
    Thank you for starting this thread - I am not imagining things.

    I have a Belkin iPhone dock. It has worked perfectly with Yosemite but the phone is not fully charged in the morning now that I am running EC.
    Grrr!
     

Share This Page