USB issue on late 2010 MBP

Discussion in 'MacBook Pro' started by Quicksilver867, Aug 29, 2010.

  1. Quicksilver867 macrumors regular

    Joined:
    Jun 25, 2007
    Location:
    Columbus
    #1
    Hello everyone- I've been using my 15" i7 MBP a lot recently, in clamshell mode with an external keyboard/mouse/monitor. While I was using it, the keyboard and mouse became unresponsive, and I looked under the mouse to see that the optical sensor was no longer lit. I ended up restarting the computer, just to see, but no change. I tried a thumb drive in the same port (further back) and its activity light lit for a split second, and went dark. Did the port REALLY just fry WHILE I was using the system?? :eek:

    I have classes...I can't have :apple: repairing this thing forever.
     
  2. DanMacApple macrumors 6502

    Joined:
    Jul 1, 2010
    #2
    Your best bet would be to at least take it in to apple and see what they feel is wrong with your system and then go from there.
     
  3. Quicksilver867 thread starter macrumors regular

    Joined:
    Jun 25, 2007
    Location:
    Columbus
    #3
    Strangely enough, it started working again. This is so weird- for a solid half hour last night, the port would do absolutely nothing. Now it's acting as if nothing happened. Ah well, I'll be grateful and take what I can get.
     
  4. fcortese macrumors demi-god

    fcortese

    Joined:
    Apr 3, 2010
    Location:
    Big Sky country
    #4
    Are both your keyboard and mouse wired and/or wireless? I have a wired keyboard hooked up to my MBP but my MM is wireless. So far no probs with the vacant USB port on my MBP. I also have two USBs on my keyboard so i use them as well for some transfer of info/docs.backups. My reason for asking is that I was wondering if the problem was that both of your USB ports were being occupied and that was somehow causing the freeze-although it certainly shouldn't! Maybe a call to apple support rather than a visit to an :apple: store may be in order. Hopefully, your MBP will behave itself.
     
  5. Quicksilver867 thread starter macrumors regular

    Joined:
    Jun 25, 2007
    Location:
    Columbus
    #5
    Both are wired- I have the Apple Pro keyboard with a standard Kensington mouse plugged into it. Both are currently operating off of the port that was previously malfunctioning...strange.
     
  6. Adidas Addict macrumors 65816

    Adidas Addict

    Joined:
    Sep 9, 2008
    Location:
    England
    #6
    Have I missed something? :eek:
     
  7. tjcad macrumors newbie

    Joined:
    Jul 29, 2010
    #7
    Post from the Future!;)
     

Share This Page