Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

USB issues with new Mojave?

Beachguy

macrumors 65816
Original poster
Nov 23, 2011
1,008
407
Florida, USA
Pretty simple. Keyboard worked. Updated to 10.14.4 from the last beta. Keyboard doesn't work now.

They keyboard in question is the Apple USB cabled keyboard. The Mac is a 2012 MBP, 16GB RAM, 512 GB SSD, 2.6Ghz i-7, non-retina. I think they keyboard is an A1243- I can't read the stuff on back of the thing.

Is anyone else having USB issues? It's not my keyboard- I swapped my wireless keyboard from my Mini for the wired, and it is working great on the Mini.
 

northernmunky

macrumors 6502a
Jan 19, 2007
800
263
London, Taipei
Turn machine off
Unplug power & all USB devices, wait 10-20 seconds
Plug back in and power up.

Also test it by holding down the option key on bootup to get the drive option screen, that way you know if the USB ports are physically working because the EFI uses a different method of connecting to USB devices. The OS uses its own drivers.
 
Comment

fheusel

macrumors newbie
Jul 10, 2012
25
4
We have the same problem here at work. A MacBook Pro Retina 13" Mid 2014 was updated to 10.14.4 and now the Apple Keyboard (German Layout, Model A1243) stopped working. Even in the EFI it doesn't work. The same keyboard works fine on different Macs. Strangely enough a Apple Keyboard with US International Layout (same Model No) works just fine.
I think the 10.14.4 update included a EFI firmware update for this MacBook Pro and there is a bug regarding this specific keyboard..
 
Last edited:
Comment

Emulous

macrumors newbie
Apr 18, 2010
6
0
Greece
My keyboard (A1243) was working fine. After the update it was not recognized. Followed the steps from above, turning off, unplugging, disconnecting and then powering it up. It worked. I own a 2012 iMac.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.