USB Key Erased Without Prompt

Discussion in 'Mac Basics and Help' started by jonn, Nov 21, 2011.

  1. jonn macrumors newbie

    Joined:
    Nov 21, 2011
    #1
    Hey everyone,

    I have an 8 GB Sony USB key on which I had stored a number of files.

    I was trying to open a picture for editing (stored on the USB key), but the program kept crashing repeatedly. When I tried to restart, the restart command would not respond (even though the OS was not frozen). I ended up having to restart the old fashioned way.

    Afterwards, my entire USB key had been wiped clean. Very confused about this as I was not prompted to delete files or format the drive. They literally just disappeared.

    Am I out of luck? Any way to do it without purchasing recovery software?

    Any help would be much appreciated.
     
  2. Amazing Iceman, Nov 21, 2011
    Last edited: Nov 21, 2011

    Amazing Iceman macrumors 68040

    Amazing Iceman

    Joined:
    Nov 8, 2008
    Location:
    Florida, U.S.A.
    #2

    From what you are describing, It seems that your flash drive got damaged; this could be the reason why part of the OS (usually the Finder) starts to delay responding.

    I had something similar happen to me and also to a friend; apparently static electricity caused the problem.

    Leave it unplug for a while, then restart your Mac, and try plugin in once again. If you still have the problem then you may try recovering your data.
    It's difficult, but not necessarily impossible to do.

    Here's a link to an app that worked for me: DDR Recovery (Professional)
    You could install it in trial mode, and if it finds something, then you decide whether to buy it or not.
    There's only one problem: it only comes as a Windows application. :(
     
  3. jonn thread starter macrumors newbie

    Joined:
    Nov 21, 2011
    #3
    That might actually explain it - had been wearing slippers on the carpet when it happened..never thought of that. Thanks!
     
  4. teleromeo macrumors 65816

    teleromeo

    Joined:
    Dec 2, 2006
    Location:
    kidnapped by aliens

Share This Page