USB Keyboard occasionally not working

Discussion in 'Mac Pro' started by treehorn, Mar 5, 2008.

  1. treehorn macrumors 6502

    treehorn

    Joined:
    Aug 21, 2007
    #1
    Has anybody else been having a problem with the keyboard that comes with the new MacPros? I got the standard USB keyboard, as I need the number pad (although I'm finding that the cable really is a pain in the @#$@ and may go back to my old white plastic Apple Bluetooth keyboard) and every now and then it simply doesn't work.

    Or rather, I will type and nothing will appear on the screen/be inputed into the document or text space.

    I thought it was that it didn't like being hooked up via the USB Hub in my HP LP3065, but I'm finding it still happens now that I rerouted it to be hooked up directly into the front USB port on the computer. But the past few days it has resumed happening.

    The odd thing is that if I change fields by clicking on a new area with the mouse I'm able to type. but until I do, nothing I type appears on the screen.

    I'm not sure if it's a Microsoft issue (since I'm noticing it when I work on Excell and Entourage) or if it's merely that 90% or more of all typing I do is on a Microsoft product (Word Documents, Excell spreadsheets, Entourage e-mails...). I honestly can't remember if I've noticed this in Quicken (but I think it has).

    Otherwise I guess it would be the keyboard (but the fact that it works when I change fields is throwing me)
     
  2. GotPro macrumors 6502

    Joined:
    Jan 29, 2007
    #2
    I noticed that as well...

    But it hasn't done it again since I moved it from the 3rd USB port in the back to the 1st USB port in the back.

    Been 3 days an no issues.

    I was :confused: too.
     
  3. treehorn thread starter macrumors 6502

    treehorn

    Joined:
    Aug 21, 2007
    #3
    I've had it plugged into the front USB, one of the back USB via a hub and I think even directly into a USB port on a Sonnet Tango Express (but I didn't have it in that too long as the cable isn't long enough, even with the extender so the fact that there was no problem in that port is probably just due to length of time).
     
  4. GotPro macrumors 6502

    Joined:
    Jan 29, 2007
    #4
    Try plugging it in directly (with the usb extension cable) to the USB port closest to the graphics card on the back.

    I, too, had issues directly in the front and on another port in the back.

    Don't know why.... but at least, for me, this solved it!
     
  5. Sharky II macrumors 6502a

    Sharky II

    Joined:
    Jan 6, 2004
    Location:
    United Kingdom
    #5
    I am using the mac pro keyboard and might mouse on my mbp because my Mac Pro is a lemon that's going back to apple...

    ...i noticed that the first time (sometimes first two times) i plug they keyboard into the USB slot on the MBP, it doesn't register... i have to unplug it and plug it back in a few times to get it working...

    Weird.
     
  6. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #6
    My 08 Keyboard would cause long startups, wouldn't play well with other devices, and eventually quit all together. I am using an old white keyboard with no issue and awaiting a aluminum replacement from Apple. I've heard several complaints about the first key press not being recognized.
     
  7. treehorn thread starter macrumors 6502

    treehorn

    Joined:
    Aug 21, 2007
    #7
    I'll give them a call. Glad, I guess, to hear that it is a somewhat wide-spread problem (beginning to think I'm the unlucky one with nuisance issues with my MacPro...still love it, especially since it's saving me tons of processing time)
     

Share This Page