USB keyboards not working after installing iHome iConnect drivers

Discussion in 'Mac Accessories' started by lifeinhd, Feb 25, 2010.

  1. lifeinhd macrumors 65816

    lifeinhd

    Joined:
    Mar 26, 2008
    Location:
    127.0.0.1
    #1
    Here's the story, I bought an iHome iConnect Media Center Keyboard for Mac since I wanted the USB ports and the iPod dock. Turns out, it's crap to type on, so I returned it. I tried to reconnect my Apple keyboard to my MacBook Pro, and it didn't respond. My mouse that was plugged into the keyboard did. I went into the Applications folder and deleted the iHome driver (I would have run the Uninstall utility on the CD (if there was one), but I had already returned the keyboard at this point). Still no success. I tried the keyboard on my PowerMac, worked like a charm. I tried another Apple keyboard I had laying around on the MacBook Pro, still no luck. I then plugged in an HP keyboard, and one of the lights on it came on, and the Keyboard Identifier window came up. I pressed the keys it told me to, but they didn't register. I closed the window and switched to a different USB port, except this time the window didn't even open.

    I've never heard of something like this happening before. Any idea as to what might be wrong?

    Thank you in advance.
     
  2. smoramarco macrumors newbie

    Joined:
    May 10, 2012
    #2
    This just happened to me - how did you fix???
     
  3. lifeinhd thread starter macrumors 65816

    lifeinhd

    Joined:
    Mar 26, 2008
    Location:
    127.0.0.1
    #3
    I honestly don't remember, it's been so long ago. Sorry. I may have ended up restoring the machine from Time Machine?
     

Share This Page