USB mouse not working after resuming from standby?

Discussion in 'macOS' started by airfang, Nov 12, 2007.

  1. airfang macrumors regular

    Joined:
    Apr 12, 2007
    #1
    These days I have experienced the situation that after resuming from standby mode, the usb mouse stopped working.

    Solution:
    - plug the usb receiver to another usb port
    - restart

    I am thinking maybe it is a software issue of Leopard, because this nvr happened before when I was using Tiger

    Anyone had the same experience?
     
  2. psonice macrumors 6502a

    Joined:
    Jul 22, 2005
    #2
    I get endless problems if I wake the computer with the mouse button, and have to unplug it then plug it back in again. Hitting a key instead, I get no problems. No idea why, but I have a cheap 3rd party mouse - it worked OK with a mighty mouse, but I can't stand using that.
     
  3. mchank macrumors regular

    Joined:
    Feb 26, 2006
    #3
    This exact same thing happened to me today. I have a Logitech VX Revolution mouse with the dongle plugged into the left usb port of my Macbook Pro. After waking the computer from overnight sleep, the mouse wouldn't respond. I plugged in my ipod and it started syncing just fine, but the mouse wouldn't respond until I plugged the dongle into the right usb port. I restarted my computer and then everything was back to normal. This must be a Leopard bug as it never happened under Tiger. I don't have any software for the mouse installed either.
     
  4. byakuya macrumors 6502a

    byakuya

    Joined:
    Jul 26, 2007
    #4
    well...with logitech mice it probably is safe to assume that the issue is caused by the driver LCC...I had my share of problems and all of them went away since I've started using steermouse...I really recommend this software/driver to anyone who likes to use logitech mice.
     
  5. mchank macrumors regular

    Joined:
    Feb 26, 2006
    #5
    I never installed the LCC driver. The mouse works by itself although I don't get to customize it except in Apple's system preferences.
     
  6. byakuya macrumors 6502a

    byakuya

    Joined:
    Jul 26, 2007
    #6
    then I honestly don't know...I also have a vx revolution plugged in (MB late 2006) and have no problems (I am using steermouse though).
     
  7. airfang thread starter macrumors regular

    Joined:
    Apr 12, 2007
    #7
    mine is also a logitech one, just some earlier model...

    but the problem is not all logitech mice have drivers for OS X, right?
     
  8. airfang thread starter macrumors regular

    Joined:
    Apr 12, 2007
    #8
    thanks, i will check it out
     

Share This Page