USB not working on iMac

Discussion in 'Mac Basics and Help' started by jamanspizza, Jan 30, 2009.

  1. jamanspizza macrumors newbie

    Joined:
    Nov 1, 2006
    #1
    I have a aluminum iMac, which has been working fine until now. A couple of hours ago I restarted it and went and did something else for a couple of hours. I then came back to find my keyboard and mouse not working, I double checked and they were both plugged in fine(I use the aluminum apple keyboard and a kensington mouse). I restarted my computer but it still did not fix the problem(I was still stuck at the login screen). I thought it might be the USB, so I plugged my iPod in, and it did not charge. While my iPod was still connected to my computer I restarted it again and as soon as the screen turned grey my iPod started charging and my mouse worked(the light turned on), but only until the grey apple logo appeared and it then stopped working again.

    I have tried every USB slot and none of them work. I'm pretty sure my computer was completely updated as well. Any help would be appreciated.
     
  2. italiano40 macrumors 65816

    italiano40

    Joined:
    Oct 7, 2007
    Location:
    NY
    #2
    you need to use disk utility to repair because you did eject it in the correct way
     
  3. jamanspizza thread starter macrumors newbie

    Joined:
    Nov 1, 2006
    #3
    How exactly would I login to do this?

    I have a iBook G4 can I gain remote access using it?
     
  4. dallenmarket macrumors newbie

    Joined:
    Feb 1, 2009
    Location:
    Vegas Baby
    #4
    lost USB

    Restart from the System Disc that came with your Mac, or the disc from which you installed 10.5. (hoping you have it) Even if it is an older OS, it will let you start and repair a HD that has a newer OS installed.

    I believe you have to have the computer running before you can set it up for remote operation. You might check the apple.com support site for using a PB as an external HD.
     

Share This Page