USB Over Current Notice Help

Discussion in 'Mac Basics and Help' started by luftwaffles08, Jul 15, 2009.

  1. luftwaffles08 macrumors newbie

    Joined:
    Jul 7, 2007
    #1
    Story time and then some begging for help.

    I have a Late 2006 Model MBP 15", 2.33ghz. Sometime in college, a roommate spilled Vodka onto my desk without my knowledge, effectively soaking one part of my laptop. Shortly afterwards, the "USB Over Current Notice" started to pop up, but only on startup. Click OK, it would disappear. It is important to note that this message comes up regardless if I have USB devices plugged in or not and the USB ports work just fine. Simply put, the logic board only thinks something is wrong.

    Fast forward to now. It now comes up roughly every 30 seconds, regardless of what's plugged in. I have taken it to the Apple store, but because of the liquid damage, I was going to be charged $1400 dollars to fix it. So that option was out, since the computer still actually works, it just thinks that it doesn't.

    So if someone would be able to help me, all I want to do is disable that notification. Either have it on permanent autohide, or have some way to just make sure it never comes up again. While I am not fantastic at using Terminal, I can follow directions with it. I also have various dependences and things from Apple's ADC that would allow me to compile a program if necessary.

    If anybody out there could help me, or point me in the direction of someone who could, I would greatly appreciate it.
     
  2. xxBURT0Nxx macrumors 68020

    xxBURT0Nxx

    Joined:
    Jul 9, 2009
    #2
    maybe you could use autoscript to make something that will continually exit out of the notification? Or maybe someone else knows of a way to disable it. Perhaps there is a way to just disable the entire USB port. I know you can do that in windows, so I'm sure you can in osx, i'm just not sure how.

    -edit-
    not sure if this will definitely work, and you may want to do a backup first or get some other opinions, but if you go to:

    finder > Macintosh HD > System > Library > System Profiler

    you will see SPUSBReporter.spreporter, which i'm sure is the reporter that keeps notifying you about the USB. Again, I would probably do a backup first, or at least make a copy of that file onto a CD or something so that if it screws stuff up you can just copy it back into that folder.
     
  3. luftwaffles08 thread starter macrumors newbie

    Joined:
    Jul 7, 2007
    #3
    Thanks for your quick response. Unfortunately, I tried removing the .reporter this afternoon and there was no change. Forgetting just the USB issue, is there a way to disable those notifications all together?
     
  4. luftwaffles08 thread starter macrumors newbie

    Joined:
    Jul 7, 2007
    #4
    i realize i am being both:

    a) impatient

    b) slightly crazy since essentially i am asking for how to manipulate my computer so it would stop reporting things that it is supposed to.

    but could someone point me to possibly another forum where i might get some assistance?
     
  5. xxBURT0Nxx macrumors 68020

    xxBURT0Nxx

    Joined:
    Jul 9, 2009
    #5
    this is honestly the busiest apple forum there is. you can try macforums, but it isn't too busy at all. What about calling apple support and asking them how to disable the notice?

    Or a google or MRoogle search
     
  6. destorm macrumors newbie

    Joined:
    Jul 26, 2009
    #6
    hi i have a problem with this "USB over current notice" also...I have a macbook pro..I'm running Leopard. i was running my mbox on one USB...and my M Audio 49 key rig on the other USB to trigger my Reason software. everything was running great. I purchased a universal mouse and wanted to use all 3 so I hooked up and old hub to one of the USB ports then tried running my Mbox thru...apparently it sucked up too much energy...so i tried going back to my normal hook up and BAM! there comes this "USB over current notice". Now I can't use my Mbox...at first i figured I may have fried the USB ports, but they both work fine with my M audio rack and anything else I hook up. I tried resetting the PMU and the PRAM but again nothing. I'm thinking it has to be the MBox...is there anyway I can reset this darn thing?
    please help.:mad:
     
  7. oculus42 macrumors 6502

    Joined:
    Dec 9, 2002
    Location:
    Maine
    #7
    USB Problems

    When it comes down to it, something is damaged, whether it's the voltage regulator for the USB connection or the sensor that checks it. My recommendation is replace the motherboard, which you can do for much less than Apple. iFixIt has your motherboard for $600. The also offer step-by-step instructions on disassembling your Mac... they even have handy "screw guides" -- a sheet of paper that with labels and boxes to set screws on so you know which screws go to what.
     
  8. oculus42 macrumors 6502

    Joined:
    Dec 9, 2002
    Location:
    Maine
    #8
    External Powered Hub

    Try picking up any USB 2.0 hub that has its own power block. I'm not sure if you damaged something by drawing too much power, but hopefully a cheap powered hub will get you back up and running.
     
  9. nullnull macrumors newbie

    Joined:
    Sep 19, 2009
    #9
    I have the same problem

    keep getting this notice without any external USB device connected, thought both my MACBOOK USB ports work well.

    I upgrade to 10.6, stil have this problem.

    I am wondering is there a tool in Mac which is similar to the DEVICE MANAGER in windows, so I can disable the USB port to get away from this usb over current notice?

    thanks
     
  10. pkghost macrumors newbie

    Joined:
    Jun 15, 2003
    #10
    bump

    i'm having this problem, too, and would appreciate a software solution.

    mine is probably a hardware problem; this comes after my motherboard crapped out on me, and the book took a trip to the repair shop. i should probably just go back to the shop. bastards.
     
  11. rollercoasta Guest

    rollercoasta

    Joined:
    Jul 13, 2014
    #11
    how to disable the Popup

    sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.UserNotificationCenter
     

Share This Page