USB Overdrive keeps disabling when plugging mouse in

Discussion in 'Mac Apps and Mac App Store' started by cleanup, Jul 6, 2007.

  1. cleanup macrumors 68030

    cleanup

    Joined:
    Jun 26, 2005
    Location:
    Toronto
    #1
    I forget when or how it started, but whenever I unplug and replug my Logitech MX310 in, USB Overdrive's settings are ALWAYS default until I run System Preferences. Then it returns to my settings.

    I don't know what the deal is. I have restarted, logged out, reinstalled, uninstalled then reinstalled, trashed preferences and re-entered everything, different USB ports...

    EVERYTHING.

    And USBOverdriveHelper is in my Login Items.

    I don't even have to click on the preference pane. I just have to open System Preferences and all the settings return. But I have to do this every time I plug the mouse in. As long as it's plugged in and I've run Sys Prefs, the settings will stay. Unplug and replug. The settings are defaulted until I run Sys Pref again.

    ARRRRRGH!

    This never happened on my iMac. What is the DEAL?! :mad:

    Me so annoyed.
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Make sure you have the latest USB Overdrive. If you're running 10.4.10 you may need to update it as it may not be compatible yet. Besides that, I'm not sure what's causing it. Is it a Universal Binary? If it isn't, that might be the reason for your trouble (assuming you have an Intel Mac).
     
  3. cleanup thread starter macrumors 68030

    cleanup

    Joined:
    Jun 26, 2005
    Location:
    Toronto
    #3
    It's the latest. I'm running 10.4.9 because 10.4.10 has wonky problems.
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    One other thing that can cause this sort of issue is conflicting mouse drivers. If this is the cause, the solution is uninstalling the offending driver. Some third-party mice come with drivers that enable extra functionality but don't get along with USB Overdrive. Perhaps you have one of these.
     
  5. cleanup thread starter macrumors 68030

    cleanup

    Joined:
    Jun 26, 2005
    Location:
    Toronto
    #5
    No. =( I never installed extra mouse drivers. A spotlight search for "Logitech" reveals nothing, as well...
     
  6. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #6
    power consumption???

    that happens with mine... not enuf power captain!
     
  7. cleanup thread starter macrumors 68030

    cleanup

    Joined:
    Jun 26, 2005
    Location:
    Toronto
    #7
    How does that make sense? It starts working and keeps working once I start Sys Pref...
     

Share This Page