USB pen-drive won't mount

Discussion in 'Mac Basics and Help' started by Fredendil, Nov 17, 2010.

  1. Fredendil macrumors newbie

    Joined:
    Nov 17, 2010
    #1
    I tried searching for a solution for this and can't find any. I've seen one other threat in here about similar problems but the variables in my case are different.

    Here's the thing, a friend of mine lent me her usb pen-drive. She uses it on a pc mostly at work. When she gave it to me she forgot to copy some files i needed so she plugged it into her macbook pro (one of the new ones from this year, intel, snow leopard and stuff), copied the files i needed on it and i took it home.

    I have an intel imac, bought on april 2009. I plugged the usb pen-drive on my keyboard usb port and nothing happened. So i took it out, plugged it in again and nada. I did it a 3rd time and this time it showed me a message saying that this pen-drive needed more power and i had to try plugging it into a different usb port. So i plugged it in the back of my imac and nothing happened, not even the "insufficient power" message. It doesn't mount, won't show up in the desktop nor in the sidebar of a finder window.

    I checked the disk utility and the pen-drive shows up there. I see the "main" pen-drive and it's "partition" (i dunno how to call it... mmm... you know, like you're seeing the "parent" drive and its "son" drive but they're "one and the same") and i can see its tech info and i noticed it's formatted NTFS. Since it worked just fine on my friend's macbook pro, i can't figure out why isn't it working in my imac. I know macs can't write NTFS, only read (mine doesn't at least) but hers wrote info in the pen-drive no prob. Another thing i noticed is that the "son" drive is grayed out. I can see its tech info but it's grayed out. Verifying the drive simply shows a message saying "Verify volume failed: Invalid request.".

    So, i have no clue as to what's going on. I could give it back and ask my friend to format it as journal or whatever it's called to be mac os compatible and copy the info back again, but i don't know if that'd be a solution until i'm able to try it in a few days. Can't ask her to format it fat32 since the file i need is larger than 4gb, so yeah.

    Any clues as to what could be the problem? I even tried unplugging any usb peripherals and no dice. I'd really appreciate the help, thank you.
     
  2. imaketouchtheme macrumors 65816

    Joined:
    Dec 5, 2007
    #2
    Open the Terminal app. Make sure only the flash drive is connected to the computer (to the back of the iMac).

    Type in "mount" (without the quotes).

    Post a screenshot of the result and post it here so I can see if it's mounted in the filesystem.
     

Share This Page