usb pendrive not showing on disk utility.

Discussion in 'Mac Basics and Help' started by bijeshkawan, Nov 18, 2014.

  1. bijeshkawan macrumors newbie

    Joined:
    Oct 11, 2014
    #1
    while creating yosemite usb installer.suddenly a message is seen as"the disk is not eject properly" at the middle of the processing and then my usb pendrive is not showing on disk utilities and in finder but,is showing on the system report profile...
    i really need to get back my pendrive back..
    please help me out of this problem..
     
  2. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #2
    Put it in another computer and reformat it if the Mac doesn't recognize it. It's possible the USB key is duff, they do wear out.
     
  3. bijeshkawan thread starter macrumors newbie

    Joined:
    Oct 11, 2014
    #3
    tried in windows pc but not showing
    it is in guid partition mode
     
  4. sharon22 macrumors regular

    Joined:
    Oct 19, 2014
    #4
    Ugh! What you just had happen is truly, truly dreaded.

    First things first: pat yourself on back, consider yourself LUCKY! (When that happened to me, my HARD DISK was irretrievably FRIED, ALL MEMORIES LOST FOREVER).

    So, never, ever ever ever ever EVER be impatient -- not only be sure to drag the Thumbdrive icon to the trash, but WAIT for the thing to stop blinking! (But, you know all of that.... I'm just typing this mainly to remind myself, because of my fried hard drive, all my fault. Ugh).

    Okay, now "getting your pendrive back." When you plug it in, it is necessary to repair it to use it. In order to repair it using software (like Disk Utility), the software needs to "see" it. When you insert your pendrive into the mac, and then fire up Disk Utility, do you see the disk in there? If not, then go to Applications/Utilities and fire up the App called, "Terminal," and type in this line exactly:

    diskutil list

    A list will appear. Do you see your drive somewhere in that list? You'll be able to tell which cryptic disk name is your pendrive, because it will say how many gigabytes it is.

    Chances are, if you can't see it in your Disk Utility program, you won't find it in Terminal, either. But, if you DO find it in Terminal, but cannot find it in Disk Utility, then in terminal, type this *exactly* (but substitute "disk0s2" with the real disk name that your pendrive got named):

    diskutil repairvolume disk0s2

    And, voila! It will be fixed.

    Now, honestly, none of this is going to happen.

    What will happen is you WON'T find it in Disk Utility, and you WON'T find it in Terminal. Why? Because I am a glass-half-empty person. "If it can go wrong, it will go wrong." So, the next step is googling for one of the professional disk repair apps (like Diskwarrior, etc.) and maybe you can find one that will offer a free Trial period, or something or another.

    And, finally, if still no luck (hey, you ARE lucky already -- you didn't fry your real hard drive!!! :)
    If still no luck, find a PC somewhere, and repeat all the similar processes. Heck, the PC might recognize it! And, if it does, then open up "My Computer," right click the disk, and click FORMAT (FAT32) and voila! It will be fixed.

    Glass still half empty? Then last resort, find one of the myriad PC programs that repair disks.... lots and LOTS of PC programs have "free trials" for 30 days or whatnot, and surely you can find one that will repair it. Once you get SOME computer to recognize the disk, then FORMAT IT IMMEDIATELY. Once it's formatted, then your Mac will be able to read it!

    Good luck!

    (never give up though... my hunch is it WILL get fixed!.... and my hunches are ALWAYS right!)
     

Share This Page