USB port isn't working on Macbook Air 13"

Discussion in 'MacBook Air' started by juliannenz, Jan 30, 2012.

  1. juliannenz macrumors newbie

    Joined:
    Feb 5, 2011
    #1
    Hi everyone,

    I'm just writing this in the hope that someone can help me.

    A week ago my computer network was hacked, and we got a tech guy over to help us out, he used a disc on my external disc drive, and since then, it hasn't worked properly. I thought it was a problem with my disc drive but then I tried to plug my iPod in and it didn't work either.

    I have shut down my computer and started it up pressing Command + Option + P + R, and nothing happened. I have installed software updates, that didn't work either.

    If nothing else works I guess I'll have to take it in to get fixed, but I'm really not looking forward to a week without a laptop.
     
  2. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #2
    Sounds like it's a good time to do a OSX reinstall.
     
  3. DaPeeps macrumors newbie

    Joined:
    Jan 31, 2012
    Location:
    Oklahoma City
    #3
    This happened on my Pro last month. I charged my iPhone off one of the USB ports each night, and everything was fine. Then at work one day I tried to plug in a flash drive and it wouldn't work. After testing - I discovered it would provide power - but wouldn't read any data. Took it to the genius bar - they agreed it was hardware and shipped it off to have the logic board replaced. Got it back 3 days later and all is well now :)
     

Share This Page