USB port issue - MBP 13" 2015

Discussion in 'MacBook Pro' started by KVertu, Dec 1, 2015.

  1. KVertu macrumors newbie

    Joined:
    Dec 1, 2015
    #1
    I have problem with the usb port on the right side. When I plug a usb hub into that port,then plug 2 usb into that hub to connect with my macbook, both usb disconnect and reconnect randomly, this doesn't happen when I plug usb hub into usb port on the left side. If I only plug 1 usb,the right one will work normally. I tried reset SMC,PRAM and install new Os but nothing changes. So is this an error or the design of MBP?
     
  2. Samuelsan2001 macrumors 603

    Joined:
    Oct 24, 2013
    #2
    There is literally no way for us to tell, it could be the hub it could be what you are plugging into it, it could be your macs USB port. I would reccomend that you use the one on the other side that doesn't have the problem.
     
  3. Marpleesi macrumors newbie

    Joined:
    Jan 12, 2015
    #3
    Maybe power is the problem?
    Does your usb hub have it own power supply? if it doesn't and both of your devices use usb power, then maybe it too much for one usb port.
    But if usb hub works on different port fine, its strange
     
  4. Swiss-G macrumors 6502a

    Swiss-G

    Joined:
    Jun 3, 2010
    Location:
    United Kingdom
    #4
    Your peripherals are probably drawing too much power.

    Have a look at the Apple support page.

    You can confirm power usage of each peripheral in System Profiler.
     
  5. KVertu thread starter macrumors newbie

    Joined:
    Dec 1, 2015
    #5
    My usb hub doesn't has a power supply but it works fine when when pluging in usb port on the left side and other laptop
    I don't think two 32GB usb flash drive could draw two much power and why that usb hub still work fine on the left usb port
     
  6. Swiss-G macrumors 6502a

    Swiss-G

    Joined:
    Jun 3, 2010
    Location:
    United Kingdom
    #6
    Use System Profiler to determine how much power each peripheral is using.
     

Share This Page