USB Port not working?

Discussion in 'Mac Basics and Help' started by Chiuy, Jun 1, 2012.

  1. Chiuy macrumors 6502

    May 24, 2011
    NorCal, Bay Area
    I have a MacBook Pro 2011 (Still under warranty for the next month)
    Today, my USB port stop working. (One of them)
    The one that is on the top is working perfectly fine and is able to connect to the computer. While the bottom one, the one nearest towards you, is not connecting to the computer.
    I plug in an USB mouse, the mouse does not recognize the USB. The computer doesn't even detect it all.
    Then I tried plugging in a hard drive and a regular USB stick... it works... kind of. The hard drive and USB stick indicted that they are receiving power, but not actually connecting to the computer.

    I'm also running bootcamp and it does not work.
    There don't seem to be any damage to the USB port nor have I dropped it.
  2. GGJstudios macrumors Westmere


    May 16, 2008
    Since it's still under warranty, take it to Apple and have them check it out.
  3. Chiuy thread starter macrumors 6502

    May 24, 2011
    NorCal, Bay Area
    I'm about too, but hoping if someone on the forum know something so I can fix it on my own since I won't be able to bring it to the Apple store until next week.
  4. satcomer macrumors 603


    Feb 19, 2008
    The Finger Lakes Region
    The try to Reset Your PRAM to see if that fixes the port.
  5. GGJstudios macrumors Westmere


    May 16, 2008
  6. satcomer macrumors 603


    Feb 19, 2008
    The Finger Lakes Region
  7. GGJstudios macrumors Westmere


    May 16, 2008
    It's most likely that restarting fixed the issue, rather than the NVRAM reset.
  8. satcomer macrumors 603


    Feb 19, 2008
    The Finger Lakes Region
    No. After many restarts it did not fix the problem. Finally the Reset of PRAM fixed the USB problem.
  9. Hoop2125 macrumors newbie

    Nov 4, 2012
    Thank You

    I was having the same issue, one of my USB ports was not working on my 2011 MacBook pro. Resetting the Pram worked. I would never have thought that would work. If i had to send it in, i would have had to get counseling to get through the withdrawal.
  10. Aliendev macrumors newbie

    Nov 25, 2012

    I know it shouldn't of fixed it, but I wanted to confirm that it does.

    And thanks for the suggestion
  11. EwanMcTeagle macrumors 6502


    Mar 26, 2012
    Lodz, Poland
    Had the same problem - one USB port not working, but simply restarting the Mac brought it back.

    Weird. Just out of curiosity - does anyone know why would one USB port just stop working all of a sudden?
  12. the3rdnumber macrumors newbie

    Feb 17, 2013
    I have the same issue with a macbook 13 2011. ill try to reset the thing you mentioned up there and say if this worked ;)
  13. shively, Feb 26, 2013
    Last edited: Feb 26, 2013

    shively macrumors newbie

    Feb 26, 2013
    I registered just to say that this fixed my MBP's USB ports.

    Thank you for saving me a trip to the Genius Bar.
  14. MikoMW macrumors newbie

    Mar 2, 2013
    I also have a 2011 MacBook Pro 13" that had a non working front USB drive. Resetting the NVRAM/PRAM did the trick.

    I am with shively in that I registered just to confirm that this worked for me as well.

    Thanks for the tip guys!
  15. Joshfaux macrumors newbie

    Mar 13, 2013
    The process I am undergoing to get my USB's working again!

    Hello all,

    I own a MacBook Pro 2011 - Warranty is gone.

    Both USB ports went down and Card Reader - Restarting, SMC and PRAM did not work - Even taking out battery and re-booting was no luck.

    Took it apart and saw that soldering was bad so re-souldered still no luck.
    I have taken it to someone who is more specialist and perhaps it may be a problem with the logic board this will most likely set me back a bit!

    Any other suggestions? other than what I have tried?..

    MacBook Pro 2011 | Crucial M4 512GB SSD | Crucial M4 128GBSSD | 8GB RAM
  16. markthedoc macrumors newbie

    Apr 24, 2007
    Northwest England. UK
    I had a problem with one of my USB ports not powering my midi controller. The USB port worked fine with some things - my iPhone etc but not with others. I reset the NVRAM and it's now working fine. Thanks for the tip. :)
  17. lyoko is great macrumors newbie

    May 31, 2013
    i am having the same problem on my mid 2012 Macbook Pro the Card Reader and USB port next to it stopped working and every time i do the PRAM or NVRAM it only fixes it for a while then it stops working again. It seems like a design fault that apple just cant pin down since it has affected every Macbook i have had since the white unibody
  18. colinm9 macrumors newbie

    Feb 17, 2013
    Same issue twice so far

    Mine is a 2011 13" MBP - with applecare thankfully!
    Had one of the two USB ports die temporarily but it would persistently "fix" itself upon re-boot. I was waiting for it to die completely before taking it in but it just kept coming back for more on reboot. Finally I took it to the genius bar with it still running. Told the genius what I had and that rebooting would only temporarily fix the port. I guess he had to believe me as he changed out the logic board.
    6-months later the new board is doing the EXACT same thing. One port drops out until reboot. What are the odds? I've never seen this exact issue on these forums and its happened to me twice on the same machine. Guess I'll take it (powered up) again.
  19. cammykool macrumors regular

    Sep 24, 2011
    Anaheim, California
    sorry to revive a dead thread but i can be another one to say the PRAM thing did it for me


    do the pram/nvram reset recommended above.
  20. Saturn007 macrumors 6502

    Jul 18, 2010
    Does the PRAM reset permanently fix it?

    How soon does the problem recur?

    In my case, I'm finding both ports on a MacBook 2013 are dropping connections from time to time. Unsure why.
  21. aih1013 macrumors newbie

    Nov 2, 2013
    PRAM reset works for me


    Just wanted to let know: PRAM reset worked for me too.

    MacBook Pro 8.2
  22. felixgun macrumors member

    Jan 7, 2012
    After reading the responses on this post, I was excited to try this on my 2011 MBP, but it didn't work :( Anyone else have a possible fix for this issue? I didn't start experiencing this issue until I installed Mac OS X Mavericks but I think that was pure coincidence...
  23. Jaymacparts macrumors newbie

    Sep 9, 2014

    Like Shively, I also just registered now just to say that this worked for me. Thanks man.
  24. dzmarko macrumors newbie

    Dec 13, 2014
    Other solution

    Having the same issue where the USB closest to the mousepad is not working. PRAM reset did not fix it. Did anyone else have another solution?
  25. teddyman macrumors newbie

    Feb 7, 2015
    nothing works

    tried reseting PRAM and SMC, restarting, shutting down. Nothing works, and both of my macbook pro USB ports do not recognize anything still. I want to connect a mouse, but it will not work.

Share This Page