USB Port - only 1 works with printer

Discussion in 'MacBook Pro' started by jlc1978, Dec 3, 2011.

  1. jlc1978 macrumors 68000

    jlc1978

    Joined:
    Aug 14, 2009
    #1
    I have an odd problem since upgrading to Snow leopard - my MBP (2010) and Canon MF 4350d only work if the printer is plunge dint the USB port closets to the front of the MBP.

    Anyone else have this problem?
     
  2. borisiii macrumors 6502

    Joined:
    Jul 4, 2010
    #2
    I had that exact same issue about a month ago with my HP printer. A restart fixed it, and the problem hasn't recurred.
     
  3. dusk007 macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #3
    I don't know how to repair it in OSX but in Windows such problems usually stem from an erronous install of the printer driver. You plug it in it loads the driver something goes wrong. You plug it in again it takes the loaded driver that doesn't work instead of just reloading it from scratch.
    Maybe a restart fixes it.
     
  4. jlc1978 thread starter macrumors 68000

    jlc1978

    Joined:
    Aug 14, 2009
    #4
    Unfortunately neither a reinstall one restart solved the problem; although I think it may be a driver issue because vuescan can access the printer from either report.
     

Share This Page