USB port quit working

Discussion in 'MacBook Pro' started by aimeeinohio, Jul 27, 2011.

  1. aimeeinohio macrumors regular

    aimeeinohio

    Joined:
    Nov 20, 2010
    #1
    I plugged in the iPhone tonight to charge & sync, and the front usb port didn't work. I can't remember the last time I used it but I know it worked LOL.

    What do do? Call Apple? :D

    Thanks peeps xoxo
     
  2. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #2
    Have you tried any other USB devices in the USB port in question?
     
  3. aimeeinohio thread starter macrumors regular

    aimeeinohio

    Joined:
    Nov 20, 2010
    #3
    No, I haven't....I don't have anything other than iDevices...iPhone, iPod Touch. :D
     
  4. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #4
    Then have you tried a different USB cable to connect it to the MacBook Pro?
     
  5. aimeeinohio thread starter macrumors regular

    aimeeinohio

    Joined:
    Nov 20, 2010
    #5
    Nope but will do so tomorrow. It does work in the 2nd port, just not the front one. Weird.
     
  6. aldejesus macrumors regular

    Joined:
    Feb 3, 2011
    Location:
    PR
    #6
    This is a known bug of the 2011 MBP, specially the 13"; affecting some of them. The only way I have found to fix this is by reseting the SMC. Hope this helps, It does for me.:)
    http://support.apple.com/kb/ht3964

    Go to he link at the middle of the page: "Resetting the SMC on portables with a battery you should not remove on your own" is a drop down menu with a few steps to reset the SMC, Its very easy.
     

Share This Page