USB Port With iPhone Spazzes Out

Discussion in 'MacBook Pro' started by totten76, Dec 18, 2015.

  1. totten76 macrumors regular

    totten76

    Joined:
    Mar 12, 2015
    #1
    So I have the 2015 15" MPB with dedicated graphics and really enjoy using this laptop over all of my previous Windows devices. However for about a month now I'm having trouble with one of the USB ports. When I try to connect my laptop to my phone through the USB port, it will continuously connect and disconnect my iPhone. It's hard to really explain but I can't download any pictures to my laptop because the phone isn't connected for more than a half second at a time. My phone will just say its charging-not charging-charging-not charging forever. Imagine plugging and unplugging the phone to the cord repeatedly and that is basically what is happening here. Yes I've turned the computer off, unplugged my USB receiver for my mouse in the other USB port (could this be the issue?) and yes I've tried plenty of cords that work just fine normally. This is really a nuisance and was wondering if anyone else has this issue or knows what to do to fix it. I am covered by AppleCare but figured this could be solved pretty simply. Thanks everyone
     
  2. mrj412 macrumors regular

    Joined:
    May 27, 2009
    #2
    I have the same notebook. Does it only occur with the USB port on the left side? I have run into the same issue but with my iPad but haven't done anything yet to get it resolved.
     
  3. totten76 thread starter macrumors regular

    totten76

    Joined:
    Mar 12, 2015

Share This Page