USB portable drive not working on Powerbook

Discussion in 'PowerPC Macs' started by shumster, Aug 31, 2005.

  1. shumster macrumors member

    Aug 15, 2001
    I purchased a USB2.0 portable hard drive (40GB), but when I connected it to my Powerbook, all I heard was a clicking and it didn't turn up in the Finder.

    BUT, when I plug it into my wife's Vaio - hey presto - there it is!

    Any ideas on what might be the problem? I've got a couple of Firewire HDD (with external power supply) which work fine, and for all intents and purposes, my USB ports appear to work OK (with mice, iPod, etc)
  2. mduser63 macrumors 68040


    Nov 9, 2004
    Salt Lake City, UT
    Your PowerBook's USB port probably doesn't provide enough power to the drive. I have a little bus-powered USB 2.0 drive, and it only works when I plug it into a powered USB hub. If I just plug it into my PB's USB port, it makes a clicking noise like you said.
  3. yellow Moderator emeritus


    Oct 21, 2003
    Portland, OR
    This seems to be a common problem with PowerBooks, and as posted before me, the issue is with power (or lack there of).
  4. tdhurst macrumors 601


    Dec 27, 2003
    Phoenix, AZ
    You sure?

    I dunno about that...powerbooks usb ports ARE powered...I have run just about everything on it, but have had problems with USB drives. Some apparently only have windows drivers. Have you visited the manufacturer's site for mac drivers?

    Note...this is why I always get firewire or dual connection drives (usb and fw). That way I have options.
  5. livingfortoday macrumors 68030

    Nov 17, 2004
    The Msp
    I don't know if it's just my old Titanium that does this, but it will only power the USB ports when it's plugged in, not when it's running on battery power. I found that out when I tried to update my shuffle on the go, and nothing happened. I thought it was broken until I plugged in the Powerbook.
  6. mduser63 macrumors 68040


    Nov 9, 2004
    Salt Lake City, UT
    They're powered, but I think they don't supply enough power for some of the USB bus-powered hard drives. As bus powered devices go, hard drives take a lot of power. Like I said, I have one, and it works great on a powered USB hub, as soon as I unplug the hub's power supply, or plug it directly into my PowerBook, it starts clicking and stops mounting.
  7. jamesW135 macrumors 6502a


    Apr 30, 2005
    What kind of USB drive was it. If the problem persists Sandisk makes a very good one.
  8. ChrisBrightwell macrumors 68020


    Apr 5, 2004
    Huntsville, AL
    Apple's notebooks tend to adhere pretty strictly to the USB spec, including power draw, while most people fudge the details a bit just to make everything work.

    If your drive is drawing more than 500 mW (I think that's right ... I'd have to look it up), that's your problem.

    EDIT: OK, so I looked it up. :) says, "The USB connector provides a single nominally 5 volt wire from which connected USB devices may power themselves. In practice, delivered voltage can drop well below 5 V, to only slightly above 4 V. A given segment of the bus is specified to deliver up to 500 mA. This is often enough to power several devices, although this budget must be shared among all devices downstream of an unpowered hub. A bus-powered device may use as much of that power as allowed by the port it is plugged into."

    Hope this helps.
  9. mtcart macrumors newbie

    Sep 10, 2005
    Possible Solution

    I purchased an aluminum USB 2.0 HD enclosure for an old 2.5" drive. It came with a cable that had two USB connectors. I tried it first on my Pismo only plugging in one of the connectors and it worked fine (USB 1.1). Then I plugged it into my new Powerbook and since the USB ports are on opposite sides, and the plugs weren't long enough to use both, I used only one connector. I got the blinking light and ticking sound but that was it. I thought the enclosure was defective - it had worked on my Pismo. I went on the Vendor's site and read many posts of people having the same problem. It was too late to return it and so I put it aside. I recently purchased a little portable hub and decided to give the HD one more try plugging in both connectors (one has to be plugged into a port on the Mac) and it works perfect. So if your cable only has one plug, you might try finding one with the split double plugs, although the HD should come with one.
  10. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    It sounds to me, too, like power is the issue, but out of curiosity, given that it doesn't show up in Finder, does it show up in Disk Utility? Just curious, should be able to read the drive even if it is formatted NTFS (although you will not be able to write to it if that is the case).

Share This Page