USB ports DEAD - El Capitan

Discussion in 'iMac' started by chrislufc1977, Feb 13, 2017.

  1. chrislufc1977 macrumors member

    Joined:
    Feb 10, 2013
    Location:
    Cambridge, United Kingdom
    #1
    Hi all.

    I've just purchased a 2008 24inch iMac which had Yosemite installed. All three of the rear USB ports were not working at all when I got it. I have since upgraded to El Capitan to see if this would resolve the issue...but alas no. El Capitan is also bringing up the "USB Devices Disabled" notification even though no devices are plugged in.

    I've tried the usual SMC and PRAM resets to no avail. Next I'm thinking of doing a clean install of El Capitan or even Lion to see if this makes any difference.

    I do have working Firewire, iSight and Bluetooth.

    I've read a few posts about USB problems with El Capitan and Yosemite so hoping this is not hardware failure.
     
  2. nambuccaheadsau macrumors 6502a

    nambuccaheadsau

    Joined:
    Oct 19, 2007
    Location:
    Nambucca Heads Australia
    #2
    I see you have done the SMC reset. Suggest you do an SMC reset, remove from mains, not just trun off, and leave at least 30 minutes unpowered, giving capacitors time to cool. Also did you do a simple upgrade to El Capitan? An erase and clean install may also be the second step to try.

    Fingers crossed.
     
  3. chrislufc1977 thread starter macrumors member

    Joined:
    Feb 10, 2013
    Location:
    Cambridge, United Kingdom
    #3
    I have left the iMac unplugged all night but still no joy. I've also tried installing El Capitan on a 2nd partition but again no USB ports.

    Guess it must be a hardware failure!
     
  4. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #4
    Something to try:
    You'll need a USB flashdrive or external drive with a "known bootable" copy of the OS on it.
    Power down.
    Insert the USB flash drive or connect the external drive
    Power up and immediately hold down the option key to invoke the startup manager.

    Does the external boot volume show up at all?
    If it DOES, I would think the USB controller circuit is ok (after all, it's recognizing the presence of a connected drive).
    If it doesn't, that might suggest hardware failure...
     

Share This Page