USB ports do not work Imac

Discussion in 'iMac' started by egghead1993, Apr 24, 2008.

  1. egghead1993 macrumors newbie

    Joined:
    Mar 1, 2008
    #1
    Hi, i have a 24" intel core 2 duo 2.4GHz iMac aluminum 1 gb ram.

    I first noticed this problem when i plugged in my ipod, it would not open itunes, appear in itunes, the desktop or finder. i managed to resolve this problem by reinstalling itunes and plugging in my ipod before i turned on the computer, but i can not change anything as it gets stuck while syncing with my ipod and says that my ipod is disconnected, i reconnect but the ipod not not appear on the screen.

    Then i plugged my PSP in (in usb mode) and it would not appear in the desktop or in finder.( it has worked before)

    Then i tried my memory sticks. the light didn't appear o either of them and they didn't pop up on the screen or in finder.

    i have all the latest software updates and firmware updates. i only noticed it started going wrong yesterday, but i haven't plugged in any of those devices for a long time.

    All the other devices connected using usb ports are working ( mouse, keyboard, USB record deck, printer.)


    any help would be much appreciated as i love macs, and it is really bugging that i can't use it for what i want to use it for

    Matt**
     
  2. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #2
    You're plugging these devices directly into the ports on the back of your iMac?
     
  3. egghead1993 thread starter macrumors newbie

    Joined:
    Mar 1, 2008
    #3
    yes, i a have tried all the ports on the mac, including the keyboard ones
     
  4. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
  5. egghead1993 thread starter macrumors newbie

    Joined:
    Mar 1, 2008
    #5
    yes, all other devices connected to the computer are working fine
     
  6. boer macrumors regular

    Joined:
    Mar 1, 2006
    #6
    Try this:
    1. Shut the Mac down
    2. Disconnect all the external devices
    3. Unplug the Mac from power
    4. Wait for 5 minutes
    5. Plugin the power, keyboard and mouse
    6. Start the Mac up
    7. Connect and test the other devices one by one

    Let us know what you learn.
     
  7. capran macrumors member

    Joined:
    Nov 28, 2003
    #7
    I noticed a some oddities in regards to my USB ports, ethernet, and mini-dvi on my new 24" as well.

    Basically my set up is the iMac, with the Apple mouse/keyboard using 1 USB port, another USB port is connected to a KVM which allows me to share an external monitor plus it's USB hub and another USB hub that has my regular keyboard and mouse on it with a PC.

    When I first got the mini-DVI to DVI adapter and connected that to my KVM, the iMac would detect the monitor, but the screen would be black. After some futzing, I finally got it to work. But then the next time I started the computer, it was black again and had to futz again. This involved either disconnecting/reconnecting the mini-DVI, or switching the KVM to another input then back. I never had this problem with my Mac Mini G4.

    Also, I started noticing that occasionally on start up or out of sleep, the ethernet would say "not connected" when it was. And I'd have to dis/reconnect physically. This hasn't happened lately though.

    And USB has been weird. One keyboard/mouse set would work, but not the other, or the 3rd USB port wouldn't work, but the one on the keyboard would. In Console I'd see something about IOUSBFamily being unable to enumerate a device.

    I think I "fixed" the USB problem, though, by disconnecting the KVM and monitor entirely and having the USB hub with my Microsoft and Logitech gear directly to the iMac. Not a permanent solution since I'd like to use both the iMac and PC.

    Could this be a hardware/driver/firmware issue?
     
  8. egghead1993 thread starter macrumors newbie

    Joined:
    Mar 1, 2008
    #8
    hi all,

    thanks for the responses,

    but i think that i may have resolved my problem.

    i made a new account then plugged in my ipod, it did not pop up but a message called 'Device Sentry asked me if i wanted to allow or block so i said allow and now it al works fine on that account not the others.

    i did a search for that program and could not find it,

    any suggestion for finding/deleting it

    thanks
     
  9. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #9
    Did you try to google:
    Device Sentry mac

    Is it your computer? How do you have apps that you don't know about installed?
     
  10. MirrorPool macrumors newbie

    MirrorPool

    Joined:
    Dec 16, 2009
    Location:
    Stockholm, Sweden
    #10
    I have a similar problem. Owning an iMac alu. 24' 2,4ghz 4ram/500gig HD.
    2 out of my 3 USBs on the back of my iMac do not work. Only the 1st one (next to the firewire).
    Tryed resetting the pram and also plugged out all the cables, wait 5-10 mins. and then replugging them again with no result :(
    Is my only way out here to send the iMac in for repair, that is getting a new motherboard ($600!!) or does anyone have any other tip?


    Greatful for any kind of help!

    Cheers from a snowy Stockholm, Sweden.
     

Share This Page