USB ports drop off - anyone ever experience this?

Discussion in 'macOS' started by polaris20, Feb 14, 2010.

  1. polaris20 macrumors 68020

    Jul 13, 2008
    I was working on some stuff for school, and all of a sudden the trackball and keyboard became unresponsive, as did the keyboard and trackpad on a mid-09 uMBP. I unplugged the USB and reconnected, but the light for the trackball did not come on as usual, indicating no power. I had to power the machine down manually, unfortunately.

    This keyboard and trackball are both plugged into a 7-port USB Belkin hub, of which has worked reliably for ages. The only variation was that a Kingston USB stick was plugged in at the time, directly to the computer.

    Console Logs don't really tell me much, other than that it was improperly shut down (obviously).

    Anyone ever have this issue?
  2. chrismacguy macrumors 68000

    Feb 13, 2009
    United Kingdom
    Have you tried plugging these into the port directly and not via the Hub??
  3. robert05au macrumors regular


    May 19, 2005
    Dubbo, NSW
    Is the 7 port hub powered externally with an adapter?

    It maybe the hub is pulling to much power from the usb port for some reason. This will cause the usb port/s to suddenly shut off working until a reboot of your mac.

    I have noticed this is a issue more so since snow leopard came out.
  4. polaris20 thread starter macrumors 68020

    Jul 13, 2008
    Well to be frank with you, it only happened the one time, and I'm being borderline paranoid :p. I just wanted to pose the question in case it happened again, at which point I'd run them directly to see.

    External power to the Belkin, and I did confirm that it's plugged in, because that was a gut feeling too. it has occurred for others, huh? Interesting. I am indeed on SL10.6....forgot to note that in my OP.
  5. superted666 Guest


    Oct 17, 2005
    I had this for months.
    After much playing about i realised it was my USB hub that was causing it.

    Took a chance on another HUB and not had a problem since.


Share This Page