USB printer connecte do USRobotics AP -> IPP not working with Lion

Discussion in 'Mac Accessories' started by d82k, Oct 3, 2011.

  1. d82k macrumors member

    Joined:
    Aug 24, 2011
    #1
    Dear All,

    I have a Samsung ML-1510 printer (http://www.samsung.com/uk/support/de...chword=ML-1510) connected to a
    USR5461 802.11g Wireless MAXg Router (firmware 3.93.35.0.8) (http://www.usr.com/support/product-t....asp?prod=5461).

    I need to print with this printer on my mac with Lion.. so:
    I just go to add printer -> IP
    Protocol: IPP
    Address: http://192.168.x.x:1631/printers/My_Printer
    Print using: Generic PostScript printer

    When I click on add I get this error: "error trying to add the printer. client-error-not-possible".

    I thought was a driver problem, so (since there are not samsung drivers for lion) I downloaded these: http://guigo.us/mac/splix/

    But the same error appears.

    I have tried to use only 192.168.x.x:1631/printers/My_Printer as Address, it let me add the printer (also if it does not find it) and it does not work.

    (connecting directly via USB the printer to the mac and using splix driver it works fine)

    Can you, please, give me some advices on how I can solve this problem?

    Printer and router works fine (I can perfectly print from my laptops and pc either with WinXP or 7).

    Thank you for your help
    dk
     
  2. helping macrumors newbie

    Joined:
    Nov 18, 2011
    #2
    For me just worked like that:

    1. I downloaded the new firmware here: http://www.usr.com/support/product-template.asp?prod=5461 - but I don't if it's really necessary.
    2. I updated the firmware in the admin area of the router - I didn't lost anything, all the configuration were there after upgrading.
    3. Add a printer in system preferences of your Mac just like this:

    Protocol: IPP
    Address: 192.168.253.1:1631 (your ip can be different here!!)
    Queue: printers/My_Printer
    Name: (whatever you want)
    Location: (blank)
    Print Using: ... Select Printer Software -> HP OfficeJet 4300 series
     

Share This Page