USB problem with Boot Camp 1.3

Discussion in 'Windows, Linux & Others on the Mac' started by Ken 1, Jul 26, 2007.

  1. Ken 1 macrumors newbie

    Joined:
    Jul 26, 2007
    #1
    I have Windows XP installed with Bootcamp 1.3 on a Macbook (2.16GHz Core2Duo) that I purchased a few weeks ago. I've been a Windows user and this is my first Mac and I've bought it for its light weight when I travel as well as to learn to use Mac.

    When I use a USB2 card reader to transfer photos from SD cards. I have a Windows program I like to use to transfer photos to the computer - Downloader Pro, which allows flexibility in renaming photos as they're downloading. If I use Downloader Pro on the Mac I'll be able to transfer the photos to my PC when I return home from travelling.

    If I use iPhoto it works properly and the 433 photos on a full 2Gb card transfer in just over 9 minutes. If I boot up in Windows, when I plug in the Card Reader I get "This device can perform faster if you connect it to a Hi-speed USB 2.0 port" so Windows is recognizing that it is a USB2 device. (I have tried both USB ports on the MacBook.) When I clicked to see details of available ports this was displayed: "Intel 82801 G (ICH7 family)USB Enhanced Host Controller - 27CC" so that appears to indicate that USB2 should be working. When I transferred the same card to the Macbook booted into Windows XP it took 56 minutes so it is obviously only working as USB 1.1 in Windows. (When I transfer the same photos with the same card reader to my HP PC it takes 11 minutes).

    I phoned Apple tech support and the guy suggested that I reload the drivers disc that was created when I installed Bootcamp. I then went further - I uninstalled Bootcamp, downloaded Bootcamp again and reinstalled it, created a new drivers CD and reinstalled Windows, but I still have the same speed problem in Windows, even though the Card Reader still works properly in Mac mode.

    Has anyone else had similar problems with the USB ports on the Macbook not registering as USB 2 in Windows mode?

    Any advice will be much appreciated.

    Ken
     
  2. jimfixx macrumors newbie

    Joined:
    Aug 1, 2007
    #2
    I have a similar problem with a first gen. macbook.

    In windows external USB storage devices don't work. I've tried an external HD and a pen drive. When I plug them in, windows recognises them as an external diskdrive and asks me to insert a media into the device.

    Bootcamp 1.1 was the same, 1.2 worked with USB drives, but blue screened windows often. 1.3 is stable, but I can't use external drives.
     

Share This Page