USB Problem with Snow leopard on Unibody Macbook!

Discussion in 'MacBook' started by jasonordeholmes, Oct 14, 2009.

  1. jasonordeholmes macrumors newbie

    Joined:
    Mar 19, 2009
    #1
    Hi all, i have done a search and couldn't find anything similar, im having a problem where if i plug in anything via USB ie a camera or my iPhone Snow leopard doesnt automatically open it or even tell me its connected and nothing appears under devices!

    Although if i i load iTunes or iPhoto they come up!!
    I want them to show up under devices to!


    Please help

    Thanks

    Jason
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    It just so happens that iPhones are designed deliberately to not show up in the Finder's devices list. A camera, however, should be showing up when connected. Check your Finder preferences - perhaps you have the "CDs, DVDs & iPods" preference set to off or mixed. Check it, if this is the case.
     
  3. jasonordeholmes thread starter macrumors newbie

    Joined:
    Mar 19, 2009
    #3
    ive checked my finder preferences and there as you explained and all ticked, annoying thing is that it worked perfectly before i upgraded to Snow Leopard!
     
  4. dbwie macrumors 6502

    Joined:
    Jun 11, 2007
    Location:
    Albuquerque, NM, USA
    #4
    Plug in your camera or iPhone. Open the "image capture" application in your application folder. Select the device. From the drop down menu at the bottom left, select what app you want to open when you connect the iPhone or camera.

    Edit: In Leopard OS, whenever I plugged in my iPhone, both iTunes and iPhoto launched, which drove me crazy because most of the time all I wanted to do was charge the phone. The default behavior has been changed to "do nothing" in Snow Leopard.
     
  5. jasonordeholmes thread starter macrumors newbie

    Joined:
    Mar 19, 2009
    #5
    that seems to of done the trick, many thanks!
     

Share This Page