Usb problem.

Discussion in 'MacBook Pro' started by paul1993, Sep 30, 2013.

  1. paul1993, Sep 30, 2013
    Last edited: Sep 30, 2013

    paul1993 macrumors newbie

    Joined:
    Sep 24, 2013
    #1
    Hi all.

    I have a new problem. :mad:
    My GT5 usb stick messed up. It always worked perfectly fine, but since a few hours ago it started to say this when I put it in the laptop: "The disk you inserted was not readable by this computer."

    I can only select "Initialize"... or "Ignore" or "Eject"...

    Basically what I get from our great source "the Internet", my usb stick got corrupted... :eek:

    When I look on videos or other forum post they just tell me to go in "Disk utility" and just repair it or reformat it.
    But my mac won't let me!

    When I click on the usb disk in "Disk utility" It won't let me click "repair" or "verify"
    and when I try to erase it it says:
    "Disk erase failed
    Disk Erase failed with the error:
    Unable to write to the last block of the device"


    So what now? :(
     
  2. nickandre21 macrumors 6502a

    Joined:
    Jun 21, 2012
    #2
    well at times like this i would plug that usb into a windows computer and check and format.
     
  3. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #3
    usb sticks tend not to be all that reliable. don't expect them to last long
     
  4. paul1993 thread starter macrumors newbie

    Joined:
    Sep 24, 2013
    #4
    Old-wiz, I you have nothing to add to the forum, why don't you just leave? Honestly I looking for a method to just be able to use my usb again, saying stuff like that isn't really useful...

    Anyways, I wish I could try on a windows os but I don't have one :D
    Is there a way to do it maybe through the terminal commands? Like forcing it?
     
  5. bobr1952 macrumors 68020

    bobr1952

    Joined:
    Jan 21, 2008
    Location:
    Melbourne, FL
    #5
    I know you want to be able to read your USB stick but you shouldn't be too harsh with Old-wiz--he was trying to be helpful by suggesting that perhaps the stick is dead and can no longer be read--certainly a genuine possibility.
     
  6. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #6
    Great way to respond to people trying to help you. Welcome to my ignore list.
     
  7. paul1993 thread starter macrumors newbie

    Joined:
    Sep 24, 2013
    #7
    Honestly I don't call that much help saying that it is just dead.
    I could have thought about that too.

    The reason I am here in the first place is to try maybe something else instead of just going to the shops and buy something new. So is it possible to do something about it?

    I tried to format it again on windows but didn't work either, it still says the last block message.
    I can't find anything on the internet about it either.

    It really sucks because it was my GT5 usb stick that I got with my signature gt5 edition... :(
     
  8. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #8
    I've gone through a handful of USB flash drives. They have a very limited write endurance. Old-wiz is most likely correct that it's dead.

    PS it's unrepairable via any software solution.
     

Share This Page