USB Problems on my new iMac i3

Discussion in 'iMac' started by Artemis Prime, Aug 20, 2010.

  1. Artemis Prime macrumors newbie

    Aug 20, 2010
    Hello guys,

    I've been a reader of these forums for years, but I've never had good reason to post any inquiries... until now.

    I got my new iMac a couple days after it was released, its the i3 27 inch model. I'm a very casual user/student, and this seemed like a great route to go. It's perfect in every way, except that it keeps spontaneously ejecting my external hard drives, then re-attaching them minutes later. This happens multiple times a day, ejecting different hard drives at different times.

    This problem occurs very spontaneously, sometimes when I am accessing the hard drives, and sometimes when I am not. The hard drives are all very different: a 2tb seagate formatted to hfs+, a lacie 500gb formated to fat 32, and an old iomega drive that may be formatted to ntfs or fat32. Two of them are usb 1.0, and one is usb 2.0, and they are all powered by their own power chords.

    I have tried checking and unchecking the "put hard drives to sleep" box in the preferences, turning my computer off (and pulling the power out the back for a while), clearing the cache in the system and offering sacrifices of crappy Microsoft products to the Apple Gods. I haven't had this problem with any other devices. I also tried the verify disk option in the disk utility, and it said their were no problems with any of them.

    This problem is making me slightly insane. I really don't want to take my Mac to a "genius" as I have no car and I have all sorts of software installed on it. They haven't been much help in the two service calls I put in either.

    Another important note is that I don't have this problem with my linux netbook or my old 2006 Macbook Pro.

    Anything I can try guys? ANYTHING??? Why is my computer doing this to me?

  2. Thermonuclear macrumors 6502

    May 23, 2009
    Are all three external drives plugged into the same power strip? (They should be.)

    Have you tried only one drive at a time? If that works, try two at a time.

    It may be that one or more drives is eating more current than it should. You might try using one or more separate powered USB hubs.
  3. old-wiz macrumors G3

    Mar 26, 2008
    West Suburban Boston Ma
    Typically, external hard drives have their own sleep mechanisms and OSx can't control that. I suspect you're drawing too much power; are the drives on a powered hub? or are they plugged in directly?
  4. Artemis Prime thread starter macrumors newbie

    Aug 20, 2010
    They are all plugged directly into my computer, and into the same powerstrip. I think I might pick up 1. a powered hub and 2. A powerstrip that I didn't get at ikea. I'll post back in the next couple of days with an update when I get my hands on these things! Thanks!

Share This Page