USB question

Discussion in 'iMac' started by brentg33, Jul 5, 2014.

  1. brentg33 macrumors 6502a

    Joined:
    Mar 5, 2007
    #1
    Hi all,

    I have late 2013 27" iMac. I am currently using all 4 USB ports and one thunderbolt
    I currently have:
    in usb:
    1. blu ray drive (bus powered)
    2. HDD for bootable back up
    3. elgato eye tv
    4. APC UPS backup

    In thunderbolt
    Firewire to thunderbolt adapter for Time Machine drive

    I have a usb hub (with one powered port) that i tired the blu ray drive on without success. I was looking for suggestions on re-doing my set up, as i am getting an audio engine D1 soon that will require a USB port.

    Not sure which things make the most sense on the hub or not
    I guess, if needed, i don't really need the blu ray drive connected all the time.

    thanks
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    You could always look into a power USB 3.0 hub.
     
  3. brentg33 thread starter macrumors 6502a

    Joined:
    Mar 5, 2007
    #3
    i have a 9 port hub, 1 powered. the bus powered drive didn't seem to want to work with it.
     
  4. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #4
    In other words, the entire hub is not powered by an external device?
    What about switching the Blu Ray drive with the HDD, if the HDD is powered by an external power adapter?
     
  5. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #5
    Well, the UPS connection can go to the hub, since the UPS does not require a bus powered connection. So that's one place to start.

    Though, I'd really consider ditching that USB hub and going for one with all ports powered. I bought this one, and while a little pricey, it's fast and offers plenty of ports, all powered. Well worth it.
     
  6. brentg33 thread starter macrumors 6502a

    Joined:
    Mar 5, 2007
    #6
    Do you have a link for it?

    I moved the ups and one non bus powdered hdd to it. So far seems ok. The drive is only used for backups from cccloner every few days. Hopefully ccc will still be able to mount the drive
     

Share This Page