USB shown but not readable

Discussion in 'MacBook Pro' started by McCloud94, Mar 13, 2017.

  1. McCloud94 macrumors newbie

    Joined:
    Sep 9, 2016
    #1
    Recently I am getting this issue...

    I've had my USB formatted as MS-DOS FAT as I want it to be compatible with both windows and mac.

    I had some issues with that (even formatting it to MS DOS FAT in Mac gave me an error) so I went with exFAT.

    Windows is able to read the USB without issues, but in Mac it's not readable. I can see it in Disk Utility though. So far, running 'First aid' on the disk seemed to help, but now not even that solves the problem now.

    Why is this happening and how would I solve this ?


    Thanks!
     
  2. ZapNZs macrumors 68020

    ZapNZs

    Joined:
    Jan 23, 2017
    #2
    Did you set it up using Mac's Disk Utility or Window's DISKPART?
    Is this a flash drive or a hard drive?
     
  3. McCloud94, Mar 13, 2017
    Last edited: Mar 13, 2017

    McCloud94 thread starter macrumors newbie

    Joined:
    Sep 9, 2016
    #3
    Just tried with both.
    Flash drive.

    Even when I format it as Mac OS Extended Journaled, it's accessible but when I plug it out and then back in, it's unaccessible again.

    And this happens with several flash drives.
     
  4. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #4
    All the same brand? I have a cheap (Lexar) 64GB that is very flaky, works, then eject and re-insert, then have to do that multiple times before it will connect. It's barely used, but a challenge to get it to mount twice in a row.
     
  5. ZapNZs macrumors 68020

    ZapNZs

    Joined:
    Jan 23, 2017
    #5
    When using DISKPART in the CMD menu, did you use the command line order of: "diskpart" --> "list disk" --> "select disk #" --> "clean" --> "convert mbr" --> (and then use either the UI in 'Manage' or continue wth the command line to create primary partition/fs=fat32)?

    Are you having USB issues with other devices, such as mice, keyboards, or hard drives? (if so, have you performed the Apple Hardware Test?)

    What OS are you running?
    Have you tried resetting the SMC & PRAM?
     
  6. McCloud94, Mar 13, 2017
    Last edited: Mar 14, 2017

    McCloud94 thread starter macrumors newbie

    Joined:
    Sep 9, 2016
    #6
    I never used diskpart to do the format. Would that be any beneficial after formatting in Disk Utility ?

    It's happening with all flash drives and even an SD card as I've just found out..

    When I click on repair, I get it working for a split second, that it goes grey again..

    Repairing file system.
    ** /dev/rdisk4s1

    ** Phase 1 - Preparing FAT

    ** Phase 2 - Checking Directories

    ** Phase 3 - Checking for Orphan Clusters

    Free space in FSInfo block (1710979) not correct (1698827)

    Fix? yes

    197 files, 6795308 KiB free (1698827 clusters)

    File system check exit code is 0.
    Updating boot support partitions for the volume as required.
    Operation successful.


    Running OS Sierra. MAcbook Pro Retina Mid 2012.
    Don't have any Apple USB devices.. will try the Apple HW test.

    Maybe 2-3 months ago, my Mac crashed severely.. at that time I've done the SMC and PRAM reset.. since then no.


    /edit:
    I've done an OS update / reboot and the issue seemed to go away.
     

Share This Page