USB Sound Input Volume Constantly Changes D:

Discussion in 'Mac Basics and Help' started by PockieLoli :3, Nov 28, 2009.

  1. PockieLoli :3 macrumors member

    Joined:
    Oct 31, 2009
    #1
    I recently bought a USB Logitech headset.
    It works fine and everything, but like the title says, the sound input volume never stays still in my system preferences! D:

    I noticed this through Skype and I've already checked Skype's sound settings and it only goes as far as choosing which device is selected; so it must be a Mac problem.

    I left my system preferences open on the sound panel while I was using my headset once and it the input volume seems to change when I speak into the mic after a moment of complete silence where the mic doesn't pick up anything.

    It's pretty frustrating because I constantly have to go to my preferences to up the input volume if it made its way down to a low value.

    Does anyone know how to prevent this?

    I have an Intel based MacBook running on Snow Leopard.
    And this is my headset.
    Yes, made for the PS2/3 but aside from the input volume it works fine and all I had to do was plug it in to use; no drivers required.

    Also... a quick unrelated question... as you'll notice, my headset only has one speaker; so should I be changing the output balance to hear all of the sounds going through my computer? My balance has always been set right in the middle.
     
  2. PockieLoli :3 thread starter macrumors member

    Joined:
    Oct 31, 2009
  3. TheSandman2236 macrumors 6502

    Joined:
    Mar 11, 2008
    Location:
    Atlanta, GA
  4. Dr.Izakaya macrumors newbie

    Joined:
    May 29, 2010
    #4
    Old thread, but here's the answer...

    So, we were having this same problem and found that it is a Skype issue, not a Mac issue. Skype has an automatic gain control that you cannot turn off in OSX versions of skype through the UI. Here are the instructions for turning it off ans well as the source webpage this comes from:

    Open the file [user]/Library/Application Support/Skype/shared.xml with textedit
    Locate the <VoiceEng> line
    Under this line, add the following:
    <AGC>0</AGC>
    Save the file

    Source: http://forum.skype.com/topic/186941-disabling-automatic-gain-control-on-mac-os-x/
     

Share This Page